Invalid Activation Code - wd2go for Android w/ MyBook Live

Had wd2go working a few days ago.  Then tried using it over wifi network, and kept getting prompted for a password trying to connect to the device.  No idea what password it was asking for, and hadn’t been prompted for same previously, so tried manual connection.  Was told that activation code was invalid.

Deleted activation code in MyBook Live dashboard, generated a new one.  wd2go continues to insist the new one is invalid.

Disabled 3g and tried again to activate over 3G.  Invalid.  Rebooted phone and tried again.  Invalid.  Deleted activation code and created yet another new one.  Invalid.

Tried emailing WD support (via WD’s support form) to troubleshoot issue.  Internal server error.  Logged out of WD support, logged back in.  Again tried sending email through support form.  Internal server error.

At this point, I suppose I’m grateful that the drive powers on when plugged in.

Try rebooting the MBL, remove the drive from WD 2go, and then try to reconnect.

Did you try the latest version of WD 2Go?