Internet Dashboard very slow and backup files not visible in smartware

Hi All,

I have a WD Live Duo setup with my laptop and I use it from time to time.

Yesterday I tried to do a backup and failed.

The problem, I can see all the shares and I can even mount and navigate them in File explorer, but Smartware would only allow me to select the HomeStream share even though it lists the others.

At the same time, the internet access to the DUO settings are very slow. So, I can login to the webpage, but then clicking on the menus leads to a timeout.

I rebooted the DUO and my laptop with no changes to the above results. Anyone has any ideas?

Many thanks in advance for any help.



Have you tried a hard reset?


if a by Hard reset you mean a reboot, yes, I tried.

if you mean reinstall the firmware, I haven’t.  I will try.

I mean a hard reset using the physical reset button on the back of the unit

Check on page 125 of the user manual

Use another browser. My best results so far with Firefox.