Internet access: file upload process won't finish

OK, so here is my Problem (live 2TB)

As long as I am in my Network, everything works fine.

When I access MyBook via Internet, Downloading/streaming works fine.


Once I to uplaod a file, it will not finisch writing it. Dosn’t matter if it’s a 5kb file or a 1gb file … uploads fast, but once it reaches the last bit it just stops … no error msg, no nothing, copyying process just hangs there indefinitly.

looks to me as if it can’t write an index or whatever …

anyone any ideas?


1 Like


I spoke with some one at WD support about this and they told me that the drive or the application in this case shows you like if the file it’s being uploaded really fast and when it gets to the last part on the loading bar is that the drive really starts writing the file to the drive.

For how long you left the app copying the file? and what was the size of the file?

1 Like

hi there,

thx 4 the reply.

I am afraid that’s not the problem.

The file size does not matter, I tried it with 5kb files and had the same results … It sits there for about 10 minutes and then disconnects.

Interesting part, it also happens in my own network when I connect via WLAN instead of cable … very strange and frustrating

Hi, Did you ever get this sorted, I have the same problem, Although i can add files over my home network. I have been trying this for weeks and even thought it was a hardware issue so i took it back and got a replacement. Still the same. i have been  trying to transfer  videos but it never seems to finish, Just sits at 5 seconds remaining.


Microsoft does INSANE things when you’re dealing with files over a WebDAV connection (which is what WD 2go is.)

The progress bar will move rather quickly as the file is copied to the LOCAL CACHE, but then will appear to hang while the file is being moved from the local Cache to the actual MBL.

The reverse is true when copying files FROM the MBL over WD 2go.

Initially, the progress bar won’t move at ALL (and in some cases, it will even say “NOT RESPONDING”) while the file is being copied from the MBL to the local cache, and then once it’s on the local cache, will start moving very quickly while it copies from the local cache to the assigned location.

@ cybersquid … no unfortunatly I haven’t :frowning:

I tried adding new folders with different writing permissions, but none worked …

everything outside my LAN network will neither finish uploads nor downloads

very frustrating …

@ TonyPh12345

… waiting it out is not solving anything … like stated before this also happens with 5kb files … and the only thing that “waiting it out” will get my is a timeout error after waiting around 1h :frowning:

I work in the IT sector so I have a broad array of testing machines @ my hands and I really tried all combinations in OS / firewalls (even win8) without any success. The only thing I now can think of is that it’s JAVA related since the share connects to the explorer via JAVA

Java doesn’t have anything to do with it.

In fact, once the connection to the share is made, WD 2go is out of it entirely.   It’s just there as a “Helper” app to establish the connection. 

At that point, the Windows OS is entirely in control.

Uoldar wrote:

I work in the IT sector so I have a broad array of testing machines

I have a hard time understanding how so many possible combinations and NONE of them work for you.

While I have two to test with – and they all work fine.

While I was typing this post, I connected to my MBLD from work and copied a folder with 40 JPG files (average of 3 Megabytes each) to my PC, 

Took about 45 seconds to do the copy.

I then copied the folder back to the MBLD as a new folder – about 45-50 seconds to do that.

Not a single hiccup…