Interner Serverfehler aka Internal Server Error still not solved?!

MacOS Yosemite, no changes since Saturday, still Discovery thinks, my “My Cloud Home Duo” is offline. Logging in with the exact same account to mycloud.com, the device is accessable. Tried logging off in Discovery and logging in again - correct pw, but internal server error. Uninstalling, re-installing WD Discovery, restarting computer, switching off the computer, starting from scratch again - no success. Also using an iMac with High Sierra, no problems there, not yet. Ideas or solutions? Thanks in advance.

if the high sierra machine is on the same network maybe it is a problem with yosemite. I would update the yosemite machine and see if that help. If it does not or you cant update for some reason i would recommend contacting WD support directly for assistance.

Well, Discovery worked on the unchanged Yosemite machine and suddenly stopped. Am I a victim of a silent WD Discovery update that is not compatible with Yosemite? Did write to staff, anyway. Thanks for your input.

Problem solved. WD Discovery is running again. I had to uninstall the program, BUT some things were not deleted by the uninstaller. Thus there were remains of the old installation and obviously these parts were the ones to cause all the trouble. Utterly helpful was https://support.wdc.com/knowledgebase/answer.aspx?ID=20731&lang=en#macos
The important part is making the hidden directories and files visible. Then you’ll see what you need to delete.
I chose to perform the deletion operations using UNIX commands. To delete a non-empty directory you will need rm -r (directory name). The ‘evil’ directory in my case was /Users/Mac_User/Library/Containers/com.wdc.WDDesktop.WDDesktopFinderSync
Substitute Mac_User for with your user name. Then reboot. If afterwards you see to many files and directories for your liking reverse the action by substituting YES by NO, so
defaults write com.apple.finder AppleShowAllFiles NO
For how long I’ll be a happy camper again, remains to be seen. But for now, life is good.
Thanks also to WD (Victoria A.) who called me next morning US time only to find out I was already fine.
I have to say that I needed almost two days to find the solution. I also originally wanted only a normal NAS but was lured into buying this product. And yes, the salespersons generally have no idea what they are selling.