Internal server error 500

Came home from work tonight… Router/modem looked fine. No Internet acess. Tried to access my net 900 router and all I got was the error in the title. Had to turn of the router and turn it back on plus plug in the wan cable 3 separate times to get back on the Internet.

Wish the router was.not so buggy. Otherwise nice router.


Not sure why it did that… never seen that, Does resettig fixed the issue?

Would bet 1 of 2 things happened and both are solved by the power cycle.  Either it over heated at some point while you were gone and locked up or it suffered from the DHCP update timeout that many report having.  What router do you have an what firmware version?  if it’s an N900 (any model) the current 1.5 firmware seems to disable the onboard fan making the routers VERY unstable due to heat.

Resetting the rotuer did fix it.

It is an N900 router.  I did see something in the logs that looked like the DHCP problem you mentioned.  I was not aware of that problem.

While I don’t have the DHCP timeout issue, I wonder if it’s because either the device giving the dhcp ip (usually your modem) has some kind of builtin blocking on UDP ports 67 and 68 of if the WD router firewall is blocking inbound responses back on either or both ports…I could see it being the case where the modem gets the dhcp update request from the router but the router then blocks the return inbound answer on port 68 and thus never gets a response.  This could also explain why it seems a lot of the people that have this issue report having success in keeping the router up if they turn off all the advanced firewall/routing features?  It could also be ethat the advanced prioritizing features simply assign the dhcp refresh request some really low value so it never gets handled before the ack packet response timeout expires?