Internal incremental Backup does not work

I tried to Setup up an incremental backup on my EX 2 ULTRA. What it acutally does is a full backup every day. This ist NOT(!) inkremental as said in another topic in here: “Where incremental backup?”.

I´m seriouly concerned that an employee of a nas manufacturer does not know the difference between incremental an full backup (read it on Wikipedia or something). Having 3 TB of data it is impossible to have daily full backups e.g. over a month! This is one of the reasons why i wanted to have a proper NAS. Synology does btw …

So when will you either fix it or rename it correctly “full backup” (second option would mean i return my NAS).

IOS logon to the webinterface does not work either by the way (new ipad and iPhone 8).

… neither does the WOL btw … so many things that do not work realiably

nor … the internal support function “Cannot upload report” or something …

Got feedback from tech support. Most issues are known, but unlikely to bbe fixed as product is close to EOL. Original statement from WD support:

I do not believe there will be any changes in that regards or how the device functions as this drive is now close to being EOL. While firmware is being released to improve its security and functionalities, it is not the first time I see the issue you are reporting but no changes have been made so far.

@Halabad Thank you for the posting.

  1. My Cloud EX2 Ultra is not near or in any stages of being EOL or End of Support
  2. More information regarding the Incremental Backup implementation on a My Cloud is located here https://support-en.wd.com/app/answers/detail/a_id/20227/kw/incremental%20backup
  3. Can you provide more information regarding MyCloud.com Web Browser Login error?

Thank you for your reply. In case you are german speaking, there is some more Information regarding the login issue here: Fehlermeldung: Die Login-Zeit ist abgelaufen. Melden Sie sich erneut an (hope the lik works).

If not, I‘m glad to translate. But until then, i‘m lazy :slight_smile:

As an addition, i´ve read the article about the implementation of your incremental backup before, however … an apple will stay an apple, doesn´t matter how often you name it banana. What the EX2 Ultra is doing is NOT an incremental backup (https://en.wikipedia.org/wiki/Backup#Incremental):

An incremental backup stores data changed since a reference point in time.[9] Duplicate copies of unchanged data aren’t copied.[7] Typically a full backup of all files is once or at infrequent intervals, serving as the reference point for an incremental repository. Subsequently, a number of incremental backups are made after successive time periods. Restores begin with the last full backup and then apply the incrementals.

@Halabad The Login Time Out error occurs on macOS 10.14.6 with Safari 12.1.2 when the Bonjour alias $HOSTNAME.local is used… If you are having this issue on iPad or iPhone Safari browser, please let me know model, iOS Version and Safari version. For now, the workaround is to use the IP address instead of the $MyCloud.local per the article below.

My Cloud Dashboard Login Time Out Safari Browser
https://support-en.wd.com/app/answers/detail/a_id/28638

@SBrown thank you for the input, I´ll try it once I have access to the machine again. I know the isse happens with my iPhone 8 IOS 12.4 and the latest safari version (as per today). Same with iPad 2019 version with IOS 12.4 and latest Safari. Also tried on the iPad with Chrome 77.0.3865.36 and Egde 44.8.0. In Private or not … same behaviour. iPad with IOS9 works like a charm.

@SBrown access using IP works!

@Halabad thanks for the updates.
CORRECTION: Regarding the incremental backup, we are using *nix hardlinks and not backing up the entire file again. Of course, Windows Explorer doesn’t support nor view hardlinks so it looks like the entire file is saved again and that double the storage space is used for each backup. This is not the case. You’ll only see the hardlinks using SSH access and checking the file to see the actual inode of the file. New files will not have the same inode as the previous file.

IE:
FailA has an inode of 123456789
Backup #1 will save the file
Backup #2 will create a hardlink inside of the new directory that points to the inode of FileA

Hope this explains better.

@SBrown oh seriously, looks like it works exactly as you said. I did not test it with ssh but checked the share size internally … it stays the same size even after 5 incremental backups. This is awesome actually, way better than the proprietary synology approach with hyper backup (which is not readable with any standard os after a NAS failure). But that information into the manual, that would have been important criterion for me as a customer.

Thank you, I seriously start loving this little machine. Honestly, did the kb article point that hard link feature out before too? Wondering because it says „copy“ that often? I hope i did not miss that before, if so: Sorry! And thank you :slight_smile: