Internal hard drives disappear and won't return, but are visible in an external usb enclosure

Between 1 and 2 years ago, I started having a problem where internal drives other than the OS drive would disappear from my system and refuse to reappear. The drives would spin up and produce heat, but wouldn’t be recognized by the OS or bios. After playing around with the WD diagnostics utility (which would usually see the drive) for a while and not getting anywhere with the test results, writing zeros to the entire drive seemed to resolve the issue(s). Upon reformatting the drive, it would remain usable anywhere from a week to a few months. After this happend repeatedly over a 6 month span to non-OS internal drives, the same thing happened to the OS drive, and I became fed up with the situation. Also worthy of note, is that I RMA’d my WD Black WD1001FALS 1TB before it happened to the OS drive. Another problem that I was having at the time was that either the motherboard or video card would start squealing when under heavy video load (from what I understand, it was inductors on the video card… maybe?), so my course of action was to buy a new motherboard and processor. Upon upgrading the motherboard and processor, everything ran like a dream, no issues, until about 6 months later (now). The same hard drive problem seems to be resurfacing now, while the squealing is no longer an issue.

Since rebuilding the computer, I have acquired a Rosewill external enclosure. When two of my internal drives recently bit the dust in the previously described manner, I tossed them into the external enclosure, and they were recognized by the OS with all files intact. To be more specific, the WD black non-OS drive went first, followed by the WD green non-OS drive a few days later. When I plugged in the hard drives to another computer via SATA, they were not recognized. Also, both drives are not recognized by the WD diagnostics utility when plugged in internally, but are visible when in the USB enclosure.

This is the most accurate/recent troubleshooting information since it is fresh in my memory:

After the WD green drive disconnected while the computer was running and I realized it was gone, I tried to reboot to see if it would reconnect. After the bios screen loaded normally, the computer got stuck on a blank screen with an underscore character blinking in the top left corner of both monitors. I tried this multiple times, same result. After powering off, disconnecting the drive, and starting the computer, the same problem persisted. Upon disconnecting all of my external hard drives and booting, the OS started up. Then I tried shutting down, booting with the drive attached, and the computer booted right up with the drive not visible to bios or the OS. The drive was then put into the external usb enclosure and was recognized by the OS with all files intact.

Also, I have tried roughly 8 sata cables.

Any help on resolving/troubleshooting this issue would be greatly appreciated.

-Old Motherboard and Processor

ECS A785GM-AD3 with an AMD Phenom II x6 1055t

-New Motherboard and Processor

Asus M5A97 with an AMD 8-Core FX-8320

-Video Card

Asus EAH4870/2DI/1GD5

-RAM (18 GB)

1x Crucial Ballistix Sport 8GB DDR3 1600

2x G Skill Ripjaws 4GB DDR3 1600 (Dual Channel)

1x Samsung 2GB DDR3 1600

-Internal Hard Drives

1x WD Black WD1002FAEX 1TB (OS drive, dual boot, 2 os partitions, 1 storage partition )

1x WD Black WD1001FALS 1TB (1 storage/scratch partition)

1x WD Green WD5000AAVS-00ZTB0 500GB (1 storage/scratch partition)

-External Hard Drives

1x WD 5000AAV External (USB) 500GB

1x WD My Book 1140 (USB) 2TB

1x Iomega External HD (USB) 1TB

-PCI Cards

1x Highpoint RocketU 1022A PCI-Express 2.0 USB 3.0 HBA Controller Card

-Power Supply



Windows 7 x64 Pro


ATX Mid-Tower w/ 2x 120mm fans

-USB Devices

HP Deskjet 2050

Lexicon Lambda

Line 6 POD X3 Live

Netgear WNDA3100 Wireless Adapter

Tascam US-1641

Microchip PICkit 2

Hi well just to cover one problem Ram is never to be mixed with other brands or even the same brand and part number. If you want 16 gig Ram it should be 2 sticks of 8 gig each that come in a 16 gig kit or you will have problems I am surprised it does not start or reboot all the time with the Ram you have. Next what 750 power supply is it Make,Model how many 12 volt rails and what are the amps on the rails. Is the system Bios up to date on the new motherboard. Just looking at your Ram setup I do not see how you could have it running properly in Dual Channel mode and all those modules wont equal up to a dual channel function. So when you look at it there could be a few configuation problems causeing the errors.