Internal drive not detected but usb is! **bleep**

Yesterday my hub turned off while watching hulu. After hours of just blinking and drive not being detected and wireless not working, everything worked.

Today while watching hulu it froze. When i turned it back on, i get the following message:

warning: formatting will erase ALL files saved in your WD TV. Are you sure you want to format?

After i select “cancel” it goes to the new firmware option on the menu since i’m using 2.08.13. My usb drive works and it also connects to the internet.

What can i do to get my internal drive back?

Any help offered would be greatly appreciated.

Thanks in advance

Is the drive visible in the disk manager? As per your description, it should, do you see any information regarding your drive. It looks like you have a file system corruption.

Oh Boy! :neutral_face: Looks that this issue has become rampant all of a sudden… Lot’s of people are having issues with the Internal drive … What is going on here?

More posts like this

BTW, I am still at Firmware release  2.04.13 till WD fixes the bugs that they introduced ever since.

It is better to be safe than sorry. If you do not have any issues with the firmware you are running, my advice would be not to upgrade.

Stay at Firmware release  2.04.13

You can get the rollback firmware from here:

The drive is not visible in the disk manager, so i’ve plugged my external up to it. Luckily hulu and netflix work but my 1TB of movies, gone!

I wonder if the drive will work in another computer?

i agree vistawall, if your current firmware is working, think twice before upgrading.  That being said, this did not happen to me after an upgrade as i’ve held off on the latest firmware for fear of harming my hub.  we see how well that worked out for me.

can i not plug it up to my laptop and try to copy the files from it?