Internal drive broken in WD Elements Play - can't update firmware through external drive?

I have two WD Play drives.    On one of these drives, the internal hard drive died a year or more ago.

I had to remove the internal hard drive, and when I did, I can now use an external hard drive with it.

When I turn it on, it thinks for a second, then says it can’t read the internal drive.  If I just click OK - it moves to the menu and i can view the external drive and all the files on it.

However… I have noticed issues with 1080p MKV files, and I see that there is a firmware update to fix this issue.

Unfortunately, when I put the firmware update into the base directory of an external drive - it won’t trigger the firmware update because it still ‘boots’ to the internal hard drive first.

Does anyone know a way around this?    Can I flip a few switches or something to make it update the firmware from the external drive?

I suppose I could pull the HDD out of the external box and put it into the WD Play - but i’d rather keep the drive seperate and mobile…


Any suggestions?

Not sure if you tried by turning the Elements play off… Connecting the drive with the firmware and then turning back on

you should get prompted to update

not sure if it’ll work since you removed the internal drive but you can try

Yes, I tried turning the unit off, connecting the drive, and turning it back on again.

Every time I turn the unit on, it pops up with the error message about not being able to detect the internal drive, I click OK (the only option) then it takes me to the main menu… it just won’t boot off the external drive (plugged into the USB)…

I think I will just have to pull the external drive out of it’s unit and plug it into the internal area of the Play.