Intermittent MyCloud Access via web or phone

We’re satisfied with this MyCloudEx2Ultra, it works perfectly within the office network. The MyCloud access has been set up 2 years ago, and it worked, as expected.

Until recently, due to the COVID-19 some people had to work from home, and they cannot login to - they get a generic error screen, saying “Cannot connect MyCloudEx2Ultra”

Here’s the strange part: when testing inside the office network (just a simple router from Verizon), the MyCloud Access ALWAYS work. Never stop working; when testing from outside the office network, it doesn’t work, regardless choice of browsers/OS (windows 7/10/Mac OS)

I already have the firmware manually updated to 2.31.204, which is the latest up-to-date. So yesterday I rebooted the device. Right after reboot, people test from their home, and reported that MyCloud access works. Great!

After 4 hours. When I got back home, tried it again, Not working! Same home network, same computer, worked 4 hours ago, not working 4 hours later

I’ve reported this issue to WD Tech Support, and got a ticket number here: Reference #: 200326-000909

But so far the only reply I got is a generic resource page:, which means nothing to me

My question is: how come right after reboot it worked for several hours, then stop working 4 hours later?

Just some update - since WD Tech Support shut down their phone service, I had a long chat session with one “Damien T”. He wasted a good 20 minutes with me, asking me to try this try that, when nothing works, he suggests me to push the reset button for 40 seconds. Then I ask: what’s going to happen after the reset? Will this wipe out all of my settings/configurations"

“Yes” he said

This is like suggesting suicide to a patient – I’m not going to do that in the middle of business. This is very irresponsible. WD should be ashamed to have somebody like this with their tech support team :rage:

1 Like

BTW: cell phone app “My Cloud” performs the same as web, when within office network, it ALWAYS works; when outside office network, it will display the rolling cloud icon, then after 60 seconds it will say “Drive offline - MyCloudEx2Ultra is not accessible”

Just tried it again, had the MyCloudEx2Ultra rebooted around 3pm, calling people around 3:10pm, MyCloud access worked from home network.

Half an hours later, tested again around 3:40pm, it does not work any more. Same network, same computer.

Test within office network, with the same user id/password, always works.

@EUPROTEIN did you send your My Cloud systems logs to support? Here’s how

Ahh, that’s how. I was wondering how to get that. OK, just generated and attached to my ticket.

Thanks a lot!

Hamed from tech support updated my ticket, asking me to “disable port forwarding” and reboot the drive. The problem is, there is nothing under “Settings” -> “Network” -> “Port Forwarding”. So how do I disable it?

Any idea? Thanks!

Do you still have problems with MyCloud Access? If so, I might not have the solution but may clarify some thing. First off, is a 3rd party service run by Western Digital. In short, it manages access to your local device via the internet which is a completely different thing than accessing it from your local networkt (LAN). So, if you have access from LAN but not from it’s mostly WD’s fault as the service is unreliable and has been down over and over again within the last four weeks (just searcht the forum for the complaints …).

However, some users report that setting cloud access in your admin dashbaord to manual has solved the problem for them. This can be done under settings > cloud access > configuration > manual but (!) requires a task called port forwarding in your router to work. In short, you must forward port 80 (http) and 443 (https) to the corresponding services in your wd device. (This is, what the support agent was mentioning). Just google for a tutorial and learn more about it, it’s not much too much complicated …

However, in my opinion I would rething my choice of Western Digital and either replace service with Nextcloud (here is a tutorial, advanced skill required) or return the devices if possible and buy something else (at least this is what I’m going to do).

Glad if this helps a bit.

I just figured this out by myself. The culprit, turns out to be our new VZ Fios Router, G1100.

Long story short: I googled around, and found the solution here => Port 80 and 443 on Gateway Router Blocking Cloud Devices <=

As explained in that post, Verizon Fios Router will block port 80/443 by default. Hence port forwarding will never work, and WD Cloud service is depending on this port forwarding.

Solution: I did exactly like the post instructed, manually config WD Cloud service on port 9080/9443, and created port forwarding rule on my G1100 router. I also took the extra steps to add Port Forwarding under WD Admin Panel->Settings->Network->Port Forwarding, added both port 9080 and 9443, for HTTP and HTTPS respectively.

After that, it’s the Open Sesame moment…

Hope this could be helpful to those in similar situation.

Good Luck

Last thing: why the cloud access works for the first 30 minutes after device reboot, and stop working after 30 minutes, still remain as a myth to me. That’s beyond my capability to figure out. Perhaps after device reboot, Fios G1100 will register the device on UPnP port, but it expires in 30 minutes? No clue.

For now as long as it works, I’m good.