Intermittent Connection on MyBookLive

We have used our MyBookLive successfully for months as a network storage for our company documents. Recently we have started having connection issues. Works fine one day and not the next. When we loose the connection to our MyBookLive I am able to see it in the Network connections and successfully ping. In the beginning it was as simple as an unplug to reboot the drive and all was good again. Last week I was able to get it up after unplugging the power, network and using the reset button. This week, nothing seems to work. Still visible on the Network but not accessible. Here are the error messages I receive when I attempt to go to mybooklive/ui/ in my browser

Warning : require(cake/basics.php) [function.require]: failed to open stream: No such file or directory in /var/www/UI/index.php on line 52

Fatal error : require() [function.require]: Failed opening required ‘cake/basics.php’ (include_path=’.:/var/www/Admin/webapp/lib/pear/includes:/var/www/UI:/var/www/UI/app/’) in /var/www/UI/index.php on line 52

 

Following the link I get

Warning (2): Invalid argument supplied for foreach() [CORE/cake/libs/configure.php, line 1122]

Code | Context

$type	=	"core"
$path	=	"libs"
$paths	=	array()

            $paths = array();

            foreach ($path as $key => $value) {

App::__paths() - CORE/cake/libs/configure.php, line 1122
App::import() - CORE/cake/libs/configure.php, line 847
App::import() - CORE/cake/libs/configure.php, line 809
require - CORE/cake/dispatcher.php, line 31
include - CORE/cake/bootstrap.php, line 51
require - APP/webroot/index.php, line 81
[main] - CORE/index.php, line 61

Fatal error : Class ‘Router’ not found in /var/www/UI/cake/dispatcher.php on line 282

The following Windows error also started coming up when I attempt to access via the mapped network drive

"An error occurred while reconnecting V: to \MyBookLive\****

Microsoft Windows Network: The local device name is already in use.

This connection has not been restored"

 

 

Have you tried to access the my book by connecting it directly to the PC? 

We have tried that. It was up long enough to to get some information downloaded before it stopped working again. Friday I tried resetting multiple times during the day but was not able to get to it at all. One time it did show up on the network but was still unable to access it.

Making the attempt again today to plug into my laptop. Not able to get a connection. MyBook ethernet has a solid amber on bottom and top light is off. I do have my card enabled and it is attempting to send packets. When connected to our router I get a solid amber on bottom and blinking green on top.

Just now is the first time I have plugged it into out router and have a green light on the front, normally red. But still not connecting. In the past even when connected and working the front light was red.