Intention to finalize a rear USB port issue (drives USB 3.0)

About a month ago, I wrote to the italian support center about this issue for the tenth time. The guy wrote me that he got told that the problem is considered “random” and that they have more important issues to solve. I think we will never get a fix. 

How can we get a real and official response from WD?

Maybe we should write a letter to [edited]

Just remember this the next time you’re tempted to buy a product from WD. That’s the only language those guys will understand.

Congratulations WD. This issue is over a year old now.

http://community.wdc.com/t5/WD-TV-Live-Streaming-Discussions/are-the-usb-ports-different/td-p/319299

Firmware 1.13.18, and this issue still exists.

I sent back my old box and a new one arrived yesterday and I get the same problems with movies freezing in the middle of the film. I also get the problem plugged into the front USB, but not so bad. This is deffo a firmware issue because if I update the player then I get bad freezing issues but if I factory restore then freezing is not half as often.

WD are completely 100 percent useless.

I’ve recently switched to the US model of the SMP (updated to 1.13.18) and so I thought I’d test the rear port with USB3 drives again. I borrowed the one that worked fine last time on my EU SMP, a

airy by CNmemory 2.5" enclosing a 1 TB Seagate drive ST1000LM 024 HN-M101MBB

and additionally a

Verbatim 2.5" 53018 enclosing a 1 TB Toshiba MK1059GSM.

Attached to the back port by a thick 20 cm cable, playing the CNMemory drive worked flawlessly over the course of a movie night. However, the Verbatim drive suddenly disconnected at ~2 hours into the movie night. Gonna try the Verbatim on the front port tonight to see if it makes a difference.

Some more tests and the results are confusing. There’s been no disconnect with the CNMemory drive ever. But the Verbatim drive acted weird during my tests:

#1: disconnected after 2 hours of playback

#2: disconnected while doing 10 min skips through Avatar, just before the end credits

#3: played through the whole 3 hours of Avatar

#4: disconnected ~46 mins into the movie and right again after another 6 mins

Given these inconsistencies it’s no wonder WD has a hard time of reproducing this bug.

I had a friend over with her new WD Passport 1 TB who lend it to me for a few days. So I’ve done 3 movie nights in a row and only yesterday the drive disconnected twice in a row (after two nights without any problems) when connected to the back USB. Connected to the front there were no further disconnects.

i have same issue with my passport 1TB USB3. However when i use the USB3 64G sandisk CZ80 USB drive, it has no problem at all.

You need to report the problem to WD Tech. Support, if you have not already done so fightclub.

Firmware 1.14.09 issue still exists.

Hi #Sprayer,

As i am in the exact same situation as you, could you tell me if you still experience the disconnect problem ?

If not, how did you resolved your problem ?

Thanks in advance,

Same issue here with most current firmware to date, but I have a couple of suggestions regarding what may be the problem. I was experiencing this problem with an mkv shortly after I accidentally hit Eject on MY BOOK rather than the USB key that was plugged unto the front USB. This Eject never worked, and eventually I had to just unplug the device even though the “wait” icon was still spinning on the Eject. After that I started experiencing this problem. Now, however, the movie in question is playing fine.

Maybe one of the following actions I performed actually made a difference. You be the judge…

  1. I plugged the My Book into my PC and I did a checkdisk. This, by the way, didn’t solve the problem after I plugged it back in immediately after. But perhaps it was a necessary step on the road to recovery so I’ll mention it here anyway. Chkdsk did, however, find and address an issue. Who knows…

  2. After I found that “Clear Media Library” from the Setup menu didn’t resolve the issue, I ejected MY BOOK again (this time it ejected fine), and using my PC I manually deleted all .wd_tv folders.

  3. The freezing and disconnecting appeared to be happening at scene changes. I went over how I created the MKV file again (I used MKVTOOLNIX - MKV Merge Gui) and I noticed that the original source contained Chapters. I re-muxed the file, this time excluding the Chapters from the selection.

As I said, the new .mkv appears to be working fine, but perhaps the above actions can either help people who are experiencing the same issue, or give WD a pointer toward the actual cause of the problem so they can fix it in a future firmware release.

Good luck

Pino

Ok folks, quick follow-up.

Sadly, my previous endeavours were in vain. I fast-forwarded through the .mkv and played chunks of it, and it all seemed well, but when my daughter tried to watch the whole movie later that day it froze again and unmounted the drive.

I then moved the USB connector to the front USB slot and, as many people here have already pointed out, it plays fine through the FRONT USB slot. So the issue seems to affect the back slot only. But, not only is a permanent cable plugged into the front of the WDTVLive unsightly, it also makes it less user friendly. Now I would have to plug a USB key with a new movie into the BACK of the box, before I could move it from there to the WD My Book - and that’s a Pain in the Proverbial, as one would then constantly have to move the WDTVLive box back and forth. I wanted a more permanent solution.

So I tried three more things, and this time the movie has been playing quite happily for over an hour. This is what I did THIS time:

  1. I once again ran a chkdsk against the disk, but this time I went for the full shebang, fixing everything it could possibly find, including sectors etc. It took hours to run, and it didn’t appear to find any issues.

  2. I de-fragmented the WD My Book

Finally, I realised that most people seem to be having issues with USB 3 connections. My WD My Book is a new 4TB drive with a USB 3 connection too. So I was wondering whether this is some incompatibility between the WDTVLive and USB 3. So …

  1. I found a little USB 2 splitter I had, and I plugged it into the WDTVLive’s back port, and I plugged my fancy USB 3 WD My Book into the splitter. Yes, I know, it brings the speed down to USB 2, but that’s plenty fast enough for even 1080p playback, so all I have to say about THAT is [shrug] and “meh”.

Thing is, the movie is now playing beautifully, through the BACK USB connection.

So there you have it. Three more things you may want to try if YOU are having this issue and, WD staff? ANYONE HOME? Does any of this ring any bells with you guys? Just checking…

*sigh*

Forget it. The whole movie played wonderfully, right up to the credits, and then it unmounted the disk. I’m done. All out of ideas. The end.

WD - over to you. Fix this or face the impotent rage of a disgruntled user… me. I shall sulk and whinge. You’ve been warned. *sob*

Hi rozeboosje,

I wonder if this is not an encoding problem.

I have 2 mkv encoded in 1080p.

Fist MKV plays flawlessly, second MKV makes the WD TV freeze and USB drive disconnected.

I have try multiple tiles and it is continuously happening with the second mkv.

Could you also test it and tell me if you experience the same situation ?

Thanks in advance,

Ferd.

Hello fredash,

Are those two mkvs two different encodings of the same source? I, too, have some mkvs encoded at h.264 and 1080p that work just fine and dandy, and others that cause this problem. The only real difference I can see is the size; one is over 4GB in size and it causes the problem, the other is under 4GB in size and it doesn’t.

If you are experiencing this with the same movie, but two different ways of encoding it, I’d love to hear what you’re doing different from one version to the next.

Pino

Don’t waste time on this, it’s definitely no encoding problem.

I thought as much. But what do you reckon it is, then? (with apologies if it’s already mentioned somewhere in the previous 9 pages)

I’m no technician but my guess is that it’s an incompatibility between USB3 and the back port (which differs from the front port somehow). Maybe some of these drives draw too much power when switched on or something.