Installing Raspbian on PiDrive - Failing

I am having issues with the instructions for running Raspbian on the PiDrive. I have followed the instructions provided on this site exactly, and I have previous experience running Raspbian (same Jessie img source) on a USB flash.

The specific issue happens when Raspbian is booting for the first time after following the instructions; it gets as far as “Starting Remount Root and Kernel File Systems.”

After a while the response is “[FAILED] Failed to start Remount Root and Kernel File Systems.” The process continues until it gets to a series of 6 jobs which seem to loop indefinitely

A reboot results in all manner of “[FAILED]…” messages.

I would appreciate any assistance in figuring out why the PiDrive is not loading the OS.

Hi Gordon,

We’re looking into this, and I just want to be sure about a few things to help us in debugging:

  • One of the errors mentions NOOBS (“apply_noobs_os_config”); was the microSD card flashed with Raspbian Jessie, or NOOBS and then Raspbian?
  • Raspbian Jessie by default is now slightly larger than the capacity of most 4GB microSD cards. Is the microSD card large enough? If not, some data might have been truncated.
  • There are some ext4 inode errors, as well as an input/output error, which are common when a device is physically disconnected. Double check to make sure the HDD cables and microSD are secure?
  • Was the root partition placed somewhere differently or unexpected? For example, the /etc/fstab entry may not correspond to the actual hard drive partition containing the root filesystem, so the partition may not be mounting correctly.

Thanks for getting back to me.
This is the 2015-11-21 Jessie.img.
The DD command resulted in no errors when pointed at the SD card; “3934257152 bytes (3.9 GB) copied”.
On it’s own the SD boots into Raspbian perfectly fine. I had also tried the Jessie-lite img, but exactly the same issue.
I have been checking to make sure the connection was secure, and I ran a scan for bad blocks, no faults found.
Root partition was set to /dev/sda2 in the cmdline.txt (with the addition of the rootdelay=5 cmd).

This is how the SD card looked in GParted when the Jessie img was loaded directly.

Some good news… and information for anyone else experiencing similar issues.

I spent quite a few hours over the weekend to diagnose the issue I had with not being able to boot from the PiDrive. After a lot of dead-end ‘rabbit holes’, these are the observations and how I got things working in the end…

  • Check that your SD card is good. Some of my testing involved an SD card that I eventually found was slightly faulty (ie I was having issues even without the PiDrive installed!) - what a waste of a few hours of my life! It wasn’t the one supplied with the PiDrive, I was trying to get full Raspbian Jessie working.
  • The latest Raspbian Jessie (Feb 2016) is too large for the PiDrive supplied SD, but the Lite is fine.
  • The instructions provided describe cloning the PiDrive image to the SDBoot image, then editing the SDBoot Cmdline.txt to reference /SDA2. I changed the order so that the edit in the reference to /SDA2 was made first, then cloned from PiDrive to SDBoot. This seemed to be the step that got the drive working.

Lesson learnt - if something isn’t working, go back to basics and change one thing at a time. Don’t assume anything and be willing to try something different!