Installing python libraries


I was trying to install which requires and then I got a warning that the python27 folder was in read-only mode.

I tried to chmod it but without success.

The user I’m using is the default sshd and su is not recognized as a command with it.

So my question is: is there any way we can login as root directly or I have to either install su and/or create a new install of python?

I’m a bit disappointed I have to say, I also own a mybook live which this one is supposed to replace andI therefore, I thought it would have the same os.

While I understand that busybox might be safer for noobs to use, it is also way too restrictive to power users.

No apt-get for exemple is killing me.

I just received the unit last night so I didn’t have any time to get familiar with the os but most of my regular commands are missing and I’m a bit lost.

Anyway, what I’m trying to install in the end is rssdler which worked like a charm on my my book live in combination with transmission: RSSDLER

Hope I can get an answer from you guys.


Hi Arasmas, this type of modifications are not supported, but maybe some of the other users can share some advice. 

The installed Python is, like most of the firmware, locked in a read-only loop device. Hence, there are no simple solutions to install Python apps. You can of course create a new install of Python and point the symlinks to this new install but keep in mind that the symlinks pointing to Python directories like lib, include, etc. will be lost on reboot and you will have to repoint the symlinks to your new Python install everytime on reboot.

And yes, the shell running on the My Cloud Mirror (like the EX2 and EX4) is the BusyBox shell, which limits the number of commands available. You can google BusyBox’s documentation to see what commands are available but also keep in mind that only a subset and not all of BusyBox commands are available on your Mirror. And in this particular case having the command su would not have helped since sshd IS the root user. Just run the id command from the shell prompt and you’ll see that. You can do a lot IF you are comfy with shell scripting and are willing to explore and learn the device’s firmware and related on your own…but not with rudimentary Linux/Unix skills I am afraid. WD provides the source code to the firmware (in the Downloads section of their site) that you can use to compile your firmware with custom changes - keeping in mind that is an unsupported use of the device and may void your warranty.

But even without compiling your custom firmware, you can still do plenty - just that most changes are not going to be permanent. The settings stored in /etc and its subdirectories are all rebuilt at boot time, as are some other directories (like /var/www, etc.). So yes, some things that you may have been able to do with your My Book Live might not be feasible, or at least easy to do. Also, a note for your reference - there are questions/posts for the EX2 and EX4 products in their respective sub-forums which you can also read to gain understanding of your device’s shell - because Mirror, EX2 and EX4 share the same firmware codebase, and there is a lot of overlap, esp. between EX2 and Mirror. The single-drive My Cloud’s firmware is a lot different and you won’t find much relevant info from that sub-forum for your Mirror.


Hi, and thank you for your answer.

Yeah I’ve had some more time to get familiar with the device and read the BusyBox documentation.

It’s a real shame they didn’t go for debian as on the my book live which is still an awesome device once you customize it correctly.

I’m afraid I’m gonna to either find another solution to my problem like running flexget on my plaex server and send the files to transmission or compile my own firmware which will take some time as I’m quite busy at work these days.

While I understand that WD got a lot of mbl back because of people playing too much with the shell, I also don’t understand why they had to also put busybox on the EX2 which is supposedly closer to a NAS than a network drive.

Anyway, I guess I’ll have to either find a custom frmware containing what I need or build one myself in the end (I’m a sysadmin so it won’t be an issue).


Can you point me in the right direction of how I would install another python and re point the symlinks.

I very rarely have to reboot my device and would be happy to relink each time versus the inconvenience of not being able to run the custom apps

Many Thanks