Installing Java on Ex2 Ultra

Ive tried installing it via this guide: [Solved] Java / JDK on EX4
but I either get “no such file or directory” or “permission denied” and if I type in “read” for instance, nothing happens. I am a noob when it comes to linux, but I’m happy to answer any questions that could help convey my issue better. My goal is to run Jdownloader headless on my Nas. Also: It says Busybox v1.20.2 then a date, and built in shell (ash) at the top of the command line window. Hopefully somebody can help me out here, because I feel like a blind person trying to drive a car.

You need to post full exact directory names you are in and the exact error messages.

Permission denied is likely just chmod + <filename/dirname> but could indicate unable to write to the destination. “read” is not a Linux command … not sure where or why you’re typing “read”.

Finally likely you will need to install JDK using chroot as the WDMyCloud volume is not writable (also likely why you see “permission denied”

It seems like you need lots guidance as a newbie so this not the best place to ask. Find a local Linux geek near by who can sit down and explain the basic tasks…