Install My Cloud in Linux Mint


#1

Hi, I recently bought the WD MyCloud and i have a laptop with Linux Mint. The salesman said to me that MyCloud can be installed and accessed by Linux but i only see windows and Mac downloads. This means that this device don’t work in my Linux Mint? If this works in Linux MInt, i will have some problems with the features of my WD MyCloud or i can have full access to all the features like a Mac User or a Wndows User? The wine can help with the windows installers? Best Regards João


#2

Its just a NAS, I use it with my Debian system.  You can either manually mount it via command line or use a file explorer and look for it under “Network”


#3

For the My Cloud using the ethernet cable to the router, it’s a bit more involved.

[Note: making these changes may invalidate the warrantee on the My Cloud device!  If that matters to you, check with WD first!]

First, open your terminal and enter this: sudo apt-get install nfs-common

Next, find the IP address your router has assigned the drive.  That will be 192.168.xxx.xxx  Note it carefully.

Open your My Cloud window, and select setting.  You’ll see Network  Select that, and you’ll see “Network node”  It will be set to DHCP.  Change it to “Static”.  It will ask for an address, and enter the exact IP number you got from your router.  Under netmask, I put 255.255.255.0 and that worked quite well for me. 

If you screw up and find your computer is going “what drive, boss?” at you, don’t panic.  Just turn the drive off for a minute, and then, as it’s starting up, stick a paper clip in the reset hole in back and hold it there for about 40 (yes, forty) seconds.  It will reset to default settings, but your data, etc., will be intact.  Then you can try it again. 


#4

 First, open your terminal and enter this: sudo apt-get install nfs-common

A word of caution…

Using apt-get on a v4 firmware MyCloud is asking for trouble, since the MyCloud v4 firmware is built using a non-standard, 64k page size, and loading standard-build Debian packages (as apt-get will) is likely to cause trouble, maybe bricking your device. Hence the work done by users to port common utilities to v4:

http://community.wd.com/t5/WD-My-Cloud/APP-MiniDLNA-original-patched-for-firmware-V4-12-2014/td-p/820103

http://community.wd.com/t5/WD-My-Cloud/Repository-with-software-worked-on-v4-firmware/td-p/829720

http://community.wd.com/t5/WD-My-Cloud/APP-WebHosting-for-firmware-V4-04-2015/td-p/838660

http://community.wd.com/t5/WD-My-Cloud/APP-Transmission-v2-84-for-firmware-V4-12-2014/td-p/770207

etc.


#5

for setting a static IP do not use the address your router assigned as the router is free to reuse this address for other devices

either identify and address outside of the routers DHCP pool and assign this as a static IP on the router, and netmask, gateway, DNS. I use this methode the next is easier and most people seem to use it

or leave the mycloud on DHCP and tell the router to reserve, lock (or whatever your router calls it) the current mycloud address. this will cause the router to give the mycloud the same address everytime it asks


#6

Using a web browser gets you access to the Dashboard. I’ve been able to use Ubuntu to manage My Cloud very efficiently. Both my Ubuntu machines are backed up to it using the built in (Ubuntu) backup program.


#7

Simply assigning a static IP address as described here fixed it foir me… THANKS!