INSTALL ENTWARE ON WD MY CLOUD HOME (SSH ACCESS, NFS SERVER, OPKG install packages)


#41

I think a system update causes me to lose SSH from my cloud home device
any easy fix ?


#43

lose SSH on first reboot…
There’s a script (see JuJu second or third post) that need to send on Cron job on boot.

Write on PC and ADB push it.


#44

Guys I am having troubling connecting to the NFS share. Linux workstation is saying unable to connect see image for details

any help is much appreciated

servers are both starting successfully


#45

anyone managed to get openvpn-openssl to work with a vpn…cant ping mine


#46

Hi guys, it may be a stupid question. But since we now have access via SSH is it possible to install OpenMediaVault?


#47

i was having problems with entware then noted that we were using Arm7 version where as our processors are armv8 and arm64 compatible so changed to that one

wget -O - http://bin.entware.net/aarch64-k3.10/installer/alternative.sh | sh


#48

Hi, maybe someone was lucky to install transmission through entware?


#49

transmisison works… but I cant get it to use the vpn via openvpn


#50

I was able to install transmission, but as im noob in linux, i have no idea how to set up directories to download everything in main 4tb partition…


#51

Hi AbuG,

Could you please share your steps to install or configure the transmission?

I have installed it, but the torrent always stop downloading at 99%. @_@

Jeff


#52

in the settings.json adjust the following parameters

download-dir": “/data/wd/diskVolume0/data/com.plexapp.mediaserver.smb/auth0|xxxxxxxxxxxxxxxxxxxxxxxxxx/torrent”,

Incomplete torrents make as a sub-directory of it and again link in the settings.json


#53

Does any one have problem with transmission then downloading big files or lets say full season of some series and after a while it shows that no space left on drive, sometimes resuming torrent helps sometimes not.


#54

Unfortunately I don’t have pc with Linux… Virtual machine will be enough? Or it has to be complete OS?


#55

Running linux directly form a thumb drive will do the trick. There are many tutorials out there that tells you step by step how to do it. You would need at least a 8 GB USB Stick for some OSs, but I would recommend getting at least 16 GB. Virtual machine should work in theory, but it will just make things more complicated at no advantage.


#56

sorry for my ignorance , i don not understand a word because i am a newbie using linux , so i have some questions
1- can i do the steps in the first post as copy and paste without understanding ?
2- after following the tutorials am i going to have a graphical user interface to use my MCH or am i going to stuck with using commands with linux to use MCH ?
3- How can I revert back to the original firmware ?
4- Is this tutorials going to flash custom firmware ?
A descriptive video will be of a great help
thank u very much and any help will be appreciated


#57

All went well until ti came to install busybox.
I am getting the same error trying to intall busybox with no such file or directory and read only.
I copy/paste the syntax. No spare spaces. I do no know what other method one used, MCH?
How to a force the permisison read and write?

root@monarch32_mini:/ # mount -o bind /data/entware.arm /opt
root@monarch32_mini:/ # /system/bin/mount -o rw,remount /system
root@monarch32_mini:/ # ./sbin/busybox --install
busybox: /usr/bin/[: No such file or directory
busybox: /usr/bin/[[: No such file or directory
busybox: /sbin/acpid: Read-only file system
busybox: /usr/sbin/add-shell: No such file or directory
busybox: /usr/sbin/addgroup: No such file or directory
busybox: /usr/sbin/adduser: No such file or directory
busybox: /sbin/adjtimex: Read-only file system
busybox: /sbin/arp: Read-only file system
busybox: /usr/sbin/arping: No such file or directory
busybox: /bin/ash: Read-only file system
busybox: /usr/bin/awk: No such file or directory
busybox: /bin/base64: Read-only file system


#58

NO luck so far
/system/bin does have busybox. I think I managed to push it from adp prompt, but if I follow the script it is not found. nothing in /opt

C:\platform-tools>adb connect 192.168.1.22

  • daemon not running; starting now at tcp:5037
  • daemon started successfully
    connected to 192.168.1.22:5555
    C:\platform-tools>adb root
    C:\platform-tools>adb disable-verity
    C:\platform-tools>adb reboot
    C:\platform-tools>adb connect 192.168.1.22
    already connected to 192.168.1.22:5555
    C:\platform-tools>adb root
    C:\platform-tools>adb shell
    root@monarch32_mini:/ # /system/bin/mount -o rw,remount /
    root@monarch32_mini:/ # /system/bin/mount -o rw,remount /system
    root@monarch32_mini:/ # mkdir /opt
    root@monarch32_mini:/ # mkdir /data/entware.arm
    mkdir: ‘/data/entware.arm’: File exists
    1|root@monarch32_mini:/ # rm -rf /data/entware.arm
    root@monarch32_mini:/ # mkdir /data/entware.arm
    root@monarch32_mini:/ # mount -o bind /data/entware.arm /opt
    root@monarch32_mini:/ # adb push d:/busybox /system/bin
    /system/bin/sh: adb: not found
    127|root@monarch32_mini:/ # /system/bin/busybox --install /system/bin
    root@monarch32_mini:/ # unset LD_LIBRARY_PATH
    root@monarch32_mini:/ # unset LD_PRELOAD
    root@monarch32_mini:/ # /opt/bin/opkg install dropbear
    /system/bin/sh: /opt/bin/opkg: not found
    127|root@monarch32_mini:/ # /opt/sbin/dropbear -p 22 -a
    /system/bin/sh: /opt/sbin/dropbear: not found
    127|root@monarch32_mini:/ # /system/bin/mount -o ro,remount /system
    root@monarch32_mini:/ # /system/bin/mount -o ro,remount /
    root@monarch32_mini:/ #

Help. i am not at all familiar with adp!

Gerry


#59

Hi Gerry,

In case you haven’t found this yet: The command “adb push d:/busybox /system/bin” is executed from the PC, not from the shell running on MCH. You have to exit from the shell (typing “exit” should work) to get back to a command prompt on your PC to do this.

Assuming you’ve downloaded the new busybox version to your d: drive, issuing the “adb push” command should cause adb (on your PC) to transfer that file to /system/bin on the MCH. Then you need to issue another “adb shell” command to get back to the shell to continue.

I suspect your next command essentially tried to install the original (bad) busybox, rather than the new one that was supposed to overwrite it. Many thanks to @ansir and his Dec 8 post with the busybox update! (His instructions did include a blank lines to indicate going back to the PC and then back to the shell, but it was kind of subtle.)

And many thanks to @juju for sharing this whole adventure! My MCH is now doing almost everything I want. I’m yet another happy original My Cloud owner duped by the terrible WD marketing move of selling this completely different machine under the My Cloud name. This thread saved me from just ripping the disk out of the MCH and throwing the box in the trash.

And in the journey I learned a bunch about rootfs and how / doesn’t even live on the disk! Juju’s once-a-minute cron job to work around that is - OK, crude - but it works. Thanks!

Jim


#60

Thanks juju, ansir, AbuG and other posters for this information. I successful managed to hack my way in using your instructions and ideas. For anyone attempting this, here are my observations on the process in case it helps you - I’m attempting to jot them down in ‘as coherent fashion as I can manage’ before the experience fades away.

  • There is a video here explaining how to open the case. I don’t speka his language but it definitely helped summon the courage to get the drive out. It’s not as simple as it appears in the video perhaps because he’s opened the case many times already. Mine was tight as b***ery and needed quite a bit of brute strength to prize apart. I managed to break 2 plastic tabs in the process.
  • Getting the lastest ubuntu desktop distro onto a USB stick (using rufus) is a great way to go. I tried using a VM first and could not successfully mount the raw WD drive. Booting the Ubuntu USB got me there really quick.
  • My partitions were sataa18 and sataa20 - This caused some grief as I mounted sataa19 at first to change build.prop. I’m surprised this isn’t a predictable location - perhaps its the way WD automate the disk build.
  • ubuntu allows you to easily install adb if you don’t want to use the Windows version.
  • I suggest not putting the MCH enclosure back together until you’ve cracked root access. I just slotted the PCB back on the drive and plugged it in.
  • The device uses a PCB made by Realtek - RTD1295PBCG A53. A rather zippy quad core 64-bit ARM system on a chip - worth googling its other uses just out of interest.
  • I might follow up the idea of attaching a UART to USB adapter to the 4-pin UART terminals on the PCB - would this give me a console I wonder?
  • The WD-flavoured Android OS already has two other busybox-like subsystems built-in (toolbox and toybox). Sadly they don’t include wget which is needed to retrieve the Entware install script.
  • I settled for running the entware.sh every 3 mins rather than 1 min.
  • I’m thinking that NFS may not be necessary in my case. The samba config file at /data/wd/samba/etc/samba/smb.conf should be hackable to set up SMB/CIFS file shares with suitable permissions (my next task). WD provide a /Public share as standard which is open to everyone (boo!) but very fast (yay!) - locking this down and adding my own shares should be a good option, I think.
  • I used the aarch64-k3.10 installer script mentioned by AbuG - thanks, man. It worked first time while I held my breath nervously.
  • I plan on firewalling the MCH now to prevent updates.

In summary, it’s a little tricky in places and knowing some unix commands really helps stitch together the separate strands in this thread. It makes your MCH into a respectable server - glad I didn’t send it back after all!


#61

Hi Kryten . sorry for disturbing you , i have red your post on installing entware on MCH but i do not know any about linux commands so please PLZZZZZZ give me a more detailed walk though or a step by step in details about rooting and installing entware . I already chalked mine and mounted the HDD but please give me the commands one by one
I need to make my MCH usable again . Please someone help me because i can not send mine back