INSTALL ENTWARE ON WD MY CLOUD HOME (SSH ACCESS, NFS SERVER, OPKG install packages)


#21

Hello dr3rmo,

The problem comes from the file: services
the copied text is formatted on the forum.

Like, I can not post the text file.

After each word press the Tab key twice

/opt/etc # cat services

sunrpc (TAB,TAB) 111/tcp (TAB,TAB) portmapper (TAB,TAB) # RPC 4.0 portmapper
sunrpc (TAB,TAB) 111/udp (TAB,TAB) portmapper

restart rcpbind :
/opt/etc/init.d/S19rpcbind restart


#22

UPDATE PART 3

Install an SFTP server with ENTWARE


#23

Thanks It works now


#24

Hello,
It looks like big step forward to make this brick useable, but I haven’t done anything like this before…
So before I start I would like to know if there are any tricky parts?
Are there any risks or disadvantages of this installation?
Pc with Ubuntu is must or it can be done without it somehow? (I have only pc with windows 10)


#25

Linux is a must to mount the volumes even I had OSX and Windows both didn’t work except I used fedora live cd
and it will void your warranty
finally if any problems we here to help
I did it because poor battery with WD Discovery app
now I use It with NAS and no battery drain on OSX
Also I installed torrent client and Rsync Server to create custom backups


#26

Hello, why do I have these problems and how to solve them? Thank you.!
root@monarch32_mini:/ # /system/bin/mount -o rw,remount /
/system/bin/mount -o rw,remount /
root@monarch32_mini:/ # mkdir /opt
mkdir /opt
root@monarch32_mini:/ # /system/bin/mount -o ro,remount /
/system/bin/mount -o ro,remount /
root@monarch32_mini:/ # mkdir /data/entware.arm
mkdir /data/entware.arm
mkdir: ‘/data/entware.arm’: File exists
1|root@monarch32_mini:/ # mount -o bind /data/entware.arm / opt
mount -o bind /data/entware.arm / opt
Usage: mount [-r] [-w] [-o options] [-t type] device directory
1|root@monarch32_mini:/ # /system/bin/mount -o bind /data/entware.arm / opt
/system/bin/mount -o bind /data/entware.arm / opt
Usage: /system/bin/mount [-r] [-w] [-o options] [-t type] device directory
1|root@monarch32_mini:/ # ./sbin/busybox -install
./sbin/busybox -install
-install: applet not found
1|root@monarch32_mini:/ # ./sbin/busybox --install /system/xbin
./sbin/busybox --install /system/xbin
busybox: /system/xbin/[: Read-only file system
busybox: /system/xbin/[[: Read-only file system
busybox: /system/xbin/acpid: Read-only file system
busybox: /system/xbin/add-shell: Read-only file system
busybox: /system/xbin/addgroup: Read-only file system
busybox: /system/xbin/adduser: Read-only file system
busybox: /system/xbin/adjtimex: Read-only file system


#27

Hello ansir,

you must remove the space between the slash and opt command:

mount -o bind /data/entware.arm /opt

to install busybox, you have to mount the system partition in RW:

system/bin/mount -o rw,remount /system
./sbin/busybox --install
system/bin/mount -o ro,remount /system

The syntax problem copy paste google translation
Sorry


#28

Thank you for your reply. My command line uses manual input, but there are still the following errors. btw,I wonder if MCH can install resilio sync?


#29

My problem has been solved. The subfolder permissions involved have been changed to read and write. The MCH synchronized folder is located in the /data/data/com. transmissionbt.WD/auth0|xxxxxxx folder. Thank you again.