Install Debian on WD My Cloud home

The Link has been posted a few times :wink:



Copy PMF files? I thought I needed bin files. :slight_smile: thanks.

Bad luck :frowning:
Looks like you need some other Software to read that file format.

Unfortunately there is no easy way of sharing those files without infringing on any Copyright…


It’s okay, i’ll figure it out. thanks.

I am trying to install Debian with OMV6 for the first time on my MCH using the files from Post #421 (MCH_Monarch_8.7.0-107_20220623).
After running the Debian installation script ( via telnet (boot from USB Stick), I reboot the MCH but then can’t connect via SSH and can’t run the script (/root/, the MCH’s IP Adress isn’t visible in the network any longer at this time, only via USB Boot and telnet. Also, the MCH reboots every 2 min.
Could someone please explain what steps are necessary to get SSH access (so OMV6 can be installed)?
Can the scipt ( also be run via telnet instead of SSH?

Latest MCH software is based on debian now. Is this still th best way to administed the device? I think entware install is best.

That’s interesting, do you have instructions for entware installation on MCH?

There’s this

I doubt this (Entware) is going to work on the 8+ releases. If you want to stay cas close as possible to the stock FW, you’d have to modify the image.cfs on SYSTEM_A and/or SYSTEM_B in order to enable SSH acces to the box. Anything else can then be persisted via Docker.

Also, ever since the Russian USB-Install files have surfaced, ther is really no need to open the case anymore. Everything can be done in the rescue roootfs.bin.


Success, my MCH is back to stock. Does it usually take more than 24 hours to get the latest FW on the drive?
Thanks for your help BTW.


The first time it almost took a week for me.
On another MCH it was updated within a couple of minutes.

Can you compile the actual steps you used for getting back to stock.
Also, we never quite established which scenario you started with :slight_smile:
This will be useful for anybody else wanting to try!

Could you please share the procedure to install the stock FW on the MCH?
I still cannot install OMV 6 because it won’t let me connect to SSH after running the debian installation script + rebooting :thinking:

I’ll write it down during the weekend but I just basically did how @RAH-66 says we should do to restore from a backup and after that I booted from the gold partition using your command. The hard part was getting the right files to recover to.

1 Like

Guys, I run Debian on MCH successfully for over a year now. Only SMB server. There is only a small problem left: when I want to reboot the server (reboot, shutdown -r…), it does hang during reboot. I can ping the device but not ssh. I have to pull the plug, wait a few seconds and then everything is back to normal.

Linux wdnas 4.1.17 #2 SMP PREEMPT Sat Jan 22 09:03:48 UTC 2022 aarch64 GNU/Linux
Description: Debian GNU/Linux 11 (bullseye)

Any ideas?

My original topic is here: I need help with fix my MCH after HDD issue

I am looking for help to restore an original filesystem to my WD My Cloud Home. I installed a new HDD and restore an original image of WD MCH partitions (Index of /fox_exe/WDMyCloud-Home/Original/). I made factory reset and set bootConfig on 2:A:2:.

Now I can ping a device from my local PC. WD MCH has an Internet connection - I can ping any address from it via terminal. I tried to add a device to my mycloud account at website, but when I have written 9-digit kod, I get information that My device is not connected to Internet.

How can I restore original software ? More details are in my previous topic. Below is an log from booting process.
Boot 2-A-2.txt (60.1 KB)

It finally let me install OMV 6!

These are the 2 issues I had to resolve:

1a) My HDD was too slow to properly create all the partitions in time (,
so I tried another HDD and ran the script line-by-line, this worked without errors

1b) I couldn’t connect to SSH because of this…

2)) /root/ was giving lots of errors, the solution is to set the correct
system date + time before executing the script, with the wrong date set it won’t download
any installation files

So now with OMV 6 running, I can’t let the HDD spin down automatically, is this even possible (because the OMV OS is running in the background all the time)?

Also, in the case I decide to restore the MCH back to stock, will this update the EMMC-Flash + bootloader (firmware) so the RAH-66-Guide will not work anymore in the future?

1 Like

The serial in the log, does that match the serial on you device?

If you have a MCH (single) then you don’t have an EMMC. If you wanted to go to stock firmware, you’d have to perform the steps @tiagalho undertook.

OMV will probably never spin down as it is simply too much running - the web-frontend alone :frowning:


Following up on the modification of the original softwere…

Since we have been gifted with the 9.4.0 firmware update my modified system_init had to be done over again. On the upside I noticed that WD didn’t remove my Docker container I previously installed (some rsyncd for syncing with my other MCHs).

Teking in those good news, I installed Portainer right away, so next time I don’t have to enable shell access anymore but can use the web Gui if further containers are needed.

Yes, I have changed it on correct via “env edit”. My device is connected to Internet since last Friday and still not working on original firmware.