Install Debian on WD My Cloud home

Попробуйте подключить WDMCH через VPN, а то может дело в этом

Я из Латвии, это Евросоюз, но попробую VPN

1 Like

Can we keep the convo in English please?

finally WDMCH was updated to 8.13.0 without any changes/action from my side,
just waited two weeks :frowning:

partition scheme not changed.
sda20, sda21 and sda22 contais old android folders and files

I found debian on sda19 inside image.cfs

What do You think, it makes sense mount image.cfs and change files? or this image was overwritten from firmware partition every system reboot?

Do You need some files from original firmware?

Do you get access to partitions using “usb rescue” or sata cable?

If possible, reset to factory/default settings, make a backup of the firmware (sections 1-23), according to this instruction


Haven’t been here for a while.
I have MCH with buster without OMV installed. I have some time to spare, so I am thinking about upgrading DEBIAN. What’s current stable version? Is there any easy to upgrade with OMV? Is it worth it? Link to nerdyproject mentioned Above is dead.
I’ll need samba, minidlna, plex will be nice.
Looking forward to some tips.
Thanks in advance

I’ll be glad if anyone here can prove me wrong and posts some proof-of-life of Debian on MCH with a bit more profound explanation how is this supposed to work..


Hey guys. Been running Debian11+OMV6 for a year now, but I would like to return my WDMCH to the original firmware, the problem is the flash drive where my backup was stored is missing and I probably will never find it again. Is there a way to return to WD firmware without a backup? If no, can I use someone else’s backup?


What proof do you expect?
It works like ordinary Linux server, with features like SAMBA (file management from Windows), miniDLNA (access from eg. Smart TV), etc…

Does anyone know the password on the new firmware’s console (serial/usb connection) ?

Old firmware went to console, but new one asks for a password (tried password and admin).

What is the current new firmware?

Try this:

Thanks for you suggestion. I was hoping to use an untouched golden image to use the @Alex-N method, that way I would not have to crack the box open.

I tried replacing /default/shadow with my own but didn’t succeed in logging in.

I wonder which credentials are actually used for the login.

The newest capture of that nerdy projects site on wayback machine:

Of course. I wonder why the original was deleted. Does the recipe not work anymore…?

Thanks Alex, that at least shows it won’t be so easy.

Would you mind sharing some details ?
Which rescue image did you use, and which partition did you have to mount to replace that file ?

Since some of the apps are now running in docker images I wondered if the console instance might not also be in a wrapper or jail of some kind.

Hey @bigdude , have a look here New software - #59 by Alex-N

The update writes to either sda19 or sda20 (SYSTEM_A or SYSTEM_B) depending on your current bootConfig. There is a image.cfs which contains a SQASHFS filesystem and is loop mounted to /usr/local/modules.
If you look at the rootfs, there are plenty of links to that part of the filesystem.

For a quick look you can open image.cfs in 7zip otherwise you’ll have to use unsquashfs.

I already tried enabling everything for remote SSH access New software - #49 by Alex-N but there is a fw_verify command in system_init which requires some certificate whihch we don’t have :frowning:

Since none of the system directories are R/W, you’d have to modify the ROOT_FS or image.cfs

I’m glad there will be some more eyes looking into this now :slight_smile:


As for the rescue image, I used the “original” Russian rescue rootfs and commented out all the image installation steps. That way I can use it from telnet or serial for new software inspection :wink:

For some reason that rescue image would not boot for me even though I have used it in the past. I did discover something odd and interesting though. Apparently when WD deployed the upgrade to the newer version they left the older image in place on the eMMC (I assume it’s in one of the ‘fallow’ partitions).

I looked through the U-Boot code and found that if you have a console connection and press the esc key you reach the U-Boot console which accepts a number of variations of the go command. In the source I saw that ‘go r’ tells the system to boot from the Flash based recovery image, so I decided to try that to see what I got.

Instead of a recovery image I found it loaded the complete preceding version of the MCHD firmware which still had an unlocked console (and a public share). All of the applets executed fine, but the new SMB share configuration was gone and the console was unlocked… It doesn’t really help with unlocking the new image, but I thought others might find it a curious alternative to using a Flash image.

If you decide to try it be warned that the changes in filesystems do force ext2fs and maybe some of the update scripts to be re-run when you reboot to the newer firmware, so that return to the newer version is a fairly slow reboot with lots of disk activity.

EDIT: Do this at your own risk, testing shows go r swaps back and forth between image A and image B. The problem is it disables local network access and then it cannot be re-enabled manually, but after a while it re-enabled local access on its own. This is a bit quirky CAVEAT EMPTOR