Inspiron 1520 with WD Black2 SSD+HDD

Hi there,

Trying to upgrade an old laptop with the Black2…

Clone didn’t complete booting so I tried a fresh install.

Fresh installs don’t complete, when Windows 7 goes into “Setup will complete after restart”

I get a bluescreen every time, or about 40% of the time after a reboot, the drive disappears from BIOS. I have to shutdown and wait a while.

I tried to update the firmware using freedos, but I get “Drive cannot be updated”, the FW is at version A1 (vs A2 of the update).

I was using normal HDDs and all of these work. So did I get a faulty drive? It works on the USB-SATA cable, but not in the bay.

Just to add that the problems always crop up, but not in the exact same places… Sometimes I get further in the install or the boot.

The drive died after I managed to install Windows 8, after three hours of use. RMAed, new drive managed to do a Windows 7 migration once, fresh out of packaging. Then hung after boot and use for thirty minutes. Is it a sata problem from 2 vs 3 on the drive? Both sides were brand new from the anti static bag.

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support

Support by Country