Initiated a EX4 reboot ... 30 minutes to reboot?

I initiated a reboot via the web front end for my EX4 and it took just a little over 30 minutes for it to reboot? It did eventually come back to life and is working normally, but why did it take 30 minutes to reboot?

Cheers, Rob.

My PR4100 took 4 hours because it has created a big number of shares such as SmartWare_1 … SmartWare_1024 and those seem to take some time to manage. You may want to check under “Resources” if that is your problem.

4 hours is not acceptable regardless of the number of shares. Something wrong with the device or the OS on the device is not configured or working correctly.

I’ve since given up on WD NAS solutions and have ordered a QNAP TS-932X.

Yes it constitutes an error that I am trying to resolve. In the normal situation with one of each type of shared resource the startup is typically 3 minutes and my question to you was whether your 30 minutes startup was cased by the same error, but if you have moved on and your query is no longer pertinent you may disregard my post.

@Antipodian @robains Thank you for reporting the issue.
Did either of you change the RAID mode, remove drives or notice “Raid Roaming” while accessing the Dashboard of your My Cloud?
Please contact support and provide your My Cloud system logs.

WD Staff

RAID 5 mode was not changed my side.

I did replace a drive about 1-2 weeks ago and it successfully rebuilt (took about 13 hours) the RAID. I ran both Quick Test, Full Test and System Test and no errors were reported in the LOG.

The more critical issue for me was not the reboot time (annoying but not critical) but the “Error 0x8007003B: An unexpected network error occurred.” see my other post here:

But like I’ve said, I needed to get this resolved and to a reliable position and have since dumped the EX4 and bought a QNAP and no issues with it so far … RAID 6.

Could be a file system, I/O Error, faulty drive sector or other type of issue.

Possibly, but no such errors were reported in the EX4 Logs … RAID 5 should be able to handle drive errors and report on them, that just didn’t happen which IS NOT what I need or want for a “reliable” storage solution.

@robains if you still have the EX4, can you provide the system logs?

@SBrown I have raised support case 111319-14251550 where I was advised to do the 4 sec reset which didn’t resolve the issue and then the 40 sec reset which still was unable to resolve it. I believe that my system logs were provided with the case but if not I am happy to provide them.

@Antipodian thanks for the update. I’ve sent your My Cloud PR4100 system logs to engineering for analysis.

The current state of affairs is that the 40 seconds reset seems to clear the resource but they are quickly repopulated at start-up: it only takes a few minutes for each class to enumerate up to what must be the maximum number which is 1024 for e.g. SmartWare and 2048 for another class; whereas the resource that I have created such as “Temp” is well-behaved.

I tried to turn “TimeMachineBackup” off and “only” 8 instances were created. If I had the option to turn off the others like “SmartWare” and “Public” I would be laughing, but there is no option in the MyCloud GUI to do that – I don’t use any of those resources they just cause me this grief!