Indexing problem, unable to access MyCloud, "spinning" Space Available

Hello everyone,…

Yesterday afternoon I transferred almost 4000 photos (approx 5.6GB in size) (and including about 10 small video clips) from my Windows lap top to my My Cloud drive - via wifi.

I have the My Cloud drive (PNo WDBCTL0040HWT-10) using 5.28.105 firmware and OS5, and have previously carried out transferring photos the same way for a number of years without issue. There is also plenty of memory remaining on the drive.

Since yesterday, I am only able to partly access My Cloud on the web, and the same via the app on my iPhone, and I am unable to log into the dashboard. Also the WD drive is no longer showing as a drive on my laptop’s network

In the app on my phone I can see the “front page” and if I go into settings there is a spinning “wheel” in the “Space Available” section. My husband is getting the same issue accessing the app on his android phone, but he can get a stage further and see his and my separate folders, but when he clicks on his, he sees a message to say that it’s “indexing”.

I’ve tried rebooting the wifi a couple of times, and turning the power off and on on the actual drive, and performing the 4 second reset, but this doesnt seem to resolve anything, The solid blue light is showing on the drive.

Any ideas please as I’m tearing my hair out having spend all afternoon trying to resolve.

Thankyou…

1 Like

@Alison814
Have you checked the back of your device to see what the rear LEDs are doing?

Does your My Cloud show on your router?

With all your devices turned on, have you rebooted your router to see if your My Cloud will show on your network?

What size storage drive is on your My Cloud?

There are several WD Knowledgebase articles on Indexing. Perhaps there is a suggestion in there for your indexing issue.

My Cloud OS 5 Cloud Access Content Indexing FAQ
Best Practice for My Cloud OS 5 Cloud Access and Indexing
My Cloud OS 5: Indexing in Progress Message
My Cloud OS 5: How To Disable and Enable My Cloud Indexing and Media Services
My Cloud OS 5: User Share Cloud Access and Indexing

Hi! Thanks for your response…

To answer your questions:

The two rear LED’s on the Ethernet cable are both lit green - the top one is flashing, the bottom one is a solid green.

I don’t know how to check if My Cloud is showing on the router, however, the Ethernet cable is plugged directly into the router.

I have rebooted the router a number of times now, and the My Cloud is no longer appearing as a network drive on my PC (though I did have it for a short time yesterday, now it’s gone again).

The drive is 2TB.

Incidentally, yesterday evening both in the iOS and android apps, both were showing “offline”. I completely unplugged My Cloud and left it overnight, and after connecting back up this morning, both devices are now back on line, but just with spinning circles when trying to access the folders. In settings - in the Device list- the connection type is “Local” but changes to “Relay” - I’ve no idea if this means anything important.

Thanks and hope to hear any theories, but for now I’m just going to leave everything running and hopefully catching up after the big transfer on Friday. :crossed_fingers:t2:

Thanks for your response, I’ve had a read through the Indexing articles, all quite interesting.

For the time being, I’m going to just leave every running, and just live in hope that it’s just going to take some time for the transfer I did on Friday to “sort itself out”. :crossed_fingers:t2::crossed_fingers:t2:

@Alison814

I am currently on my desktop computer, Windows 11 Pro 23H2 with all updates.

The image below shows what I have showing under Network, and I have my WDMYCLOUD two connections highlighted in yellow.

If I reboot my computer everything will probably disappear except for my desktop computer. The next time I reboot my router everything will show again.

I do have my shortcuts to my WD devices on my desktop. The ones on the left open up the dashboard and the right open my Public share.

image

What happens if you type the highlighted address below in the address bar? Be sure to use the name of your device.
image

I’ve left MyCloud connected all day, the green lights on the Ethernet cable continue to be lit green (as above), but now it’s showing as “offline” in the app.

I still cannot see it as a drive on my desktop PC - even having done a couple of reboots.

I can’t get anything to come up if I type the address as you suggested in the address bar //wdmycloud - nothing happens.

When I try to get into the homemycloud website, I can get past the 2factor authentication stage, then I get asked to put in a 9 digit code and I have no idea what this is, as it’s not on the bottom of the drive!

:thinking::weary:



The site https://home.mycloud.com/ is for the My Cloud Home, not My My Cloud. My Cloud Home is a different device. For My Cloud one uses https://os5.mycloud.com/.

Repeatedly restarting a My Cloud typically doesn’t solve anything and may cause indexing to start over or restart if not finished.

If you cannot access the My Cloud Dashboard by it’s device name (example for single bay: http://wdmycloud or http://wdmycloud.local) , then try accessing it by it’s IP address. One can typically find the IP address for their My Cloud by accessing their local network router or gateway’s administration page and checking the DHCP section for connected network clients.

@Bennor

Good morning and thanks for the info. I’ve woken up this morning and my device is off line - again. I’ve managed to get into MyCloud (see photo) which again tells me it’s off line. On the device itself - the blue light is still solid on the front, and on the rear on the Ethernet connector the top light is flashing green, the bottom is solid green. It’s still plugged into the router which is all working fine and connected to the internet.

I’m still unable to access the dashboard, and as I now have the IP address, on typing that into my browser noting happens - just a spinning wheel.

Would it be possible for a more detailed explanation on what I do with the IP address regarding the DHCP section.

Any help appreciated as I’m at my wits end!

Thankyou….

Generally most routers or gateways will have an administration page where one can see a listing of devices that have obtained an IP address from the router or gateway’s DHCP server. Sometimes the administration access information is listed somewhere on the router or gateway (usually bottom or side). Otherwise one can search the internet for how to access the administration page for their router or gateway.

If you cannot access the router or gateway’s administration page there are software programs available and other methods that can search the local network for connected clients and provide their IP addresses.

Once one finds the My Cloud IP address they can input that into their web browser’s address bar to try and access the My Cloud Dashboard. Or they can try to access the My Cloud Shares using the IP address by inputting it into Windows File Explorer’s address bar.

Web browser example: http://192.168.1.10
Windows file explorer example: \\192.168.1.10

The IP address is taken from the router settings (shown on photo). I’ve entered this into my web browser, and nothing happens - just the spinning circle…

What can I try next please



? :thinking:

One can try pinging the My Cloud IP address to see if it responds.

As a troubleshooting step, one should replace the network cable between the My Cloud and the router.

One can try a 40 second reset if they haven’t tried it already. Make sure to follow the proper method for pin resetting a My Cloud device.
How to Pin Reset and System Only Restore a My Cloud OS 5

Otherwise one can leave the My Cloud alone (powered on with front blue LED) for several days to see if the My Cloud finishes indexing or error checking the drive. Some have found the indexing can take longer than 24 hours.

@Bennor

Thanks once again…. I’ll check out and try some of these tomorrow (in the UK) as I’ve had a really busy evening. I am a bit loathe to try the 40 second reset at this stage, in case it wipes my data.

I’ll let you know how I get on…. :+1:t2:

A 4 second or 40 second pin reset is supposed to be non data destructive. Per the provided link above:

The pin button on the back of a My Cloud can be used to perform a 4 or 40 second reset.

The process is Not Data Destructive.
It will not impact data or shares on the drive.

Hi @Bennor

Further to your last message, and as it’s now 4 days since the issues began, I have carried out further troubleshooting as you suggested:

I tried pinging the MyCloud IP address - everything came back as normal - ie no errors.

I replaced the network cable - no change.

I carried out the 40 second reset - which at first looked to be successful; I managed to set up from scratch - got the dashboard and MyCloud website back, and I could see that the device had started indexing. However after about 10 minutes, and showing 1% indexed, the dashboard “locked up”, became unresponsive and inaccessible - the same as the website, the usual spinning wheel.

I performed the 40 second reset again, and exact the same happened again.

In the app - I’m getting the spinning wheel in the space available field, and the connection type is “relay”. Initially this was “direct” but seems to have changed.

I feel like I’m back to square one. The device has about 25 years worth of photographs (I’m a keen amateur photographer) and all of my and my husband’s digital music, so I’m becoming increasingly worried.

Do you have any further advice please…?





The Indexing in OS5 can take a very (very) long time on the single bay/single drive My Cloud due to the device’s low powered processor and limited RAM. Repeatedly restarting or resetting the My Cloud does not help and does not speed up the indexing process. The indexing process can and often does render the single bay My Cloud inaccessible and unusable.

If the device is indexing leave it alone for 24 to 48 hours then see if you can access the My Cloud Dashboard.

See the various indexing WD Support documents previously linked up discussion last week. One of them explains how to disable indexing IF one can access the My Cloud Dashboard.

Thankyou - for the time being, I will forget about it for a few more days and leave it to do its thing - hopefully the right thing. :crossed_fingers:t2:

1 Like

最后结果如何?解决问题了嘛?我和你遇到一模一样的问题,至今还没有解决。我在想是不是固件升级后导致的问题?