Incorrect DNS server


#1

Hi,

Just tried to install my WD Live Media Player onto my network, but it cannot connect. Tried every kind of settings (read a lot of WD community threads about the DNS problem) but it still not work. Automatic configuration does not work. The device cannot get a IP address, even if I link the devices MAC to a IP address in router configuration ( Linksys WRT320N) These are my current settings:

IP: 192.168.1.110

Subnet: 255.255.255.0

Gateway: 192.168.1.1

DNS: 192.168.1.1

Other configuration I have tried:

  • Subnet 255.255.0.0
  • DNS: (providers) DNS1 and DNS2 found on ipconfig /all
  • DNS: (open DNS) 4.2.2.2 and 208.67.222.222
  • Tried every possible combination there is to make with these settings

I also tried to make DNS addresses static in router configuration. But automatic and manual DNS cannot be found. I have updated the WD and router to the newest firmware, have unplugged the WD device and set it to factory defaults. Still no DNS. This is really driving me mad!


#2

Are you connecting to your router via a lead or wireless adaptor.


#3

I am connected via wired network. I don’t have a wireless adapter that is supported.


#4

I have a small update:

Tried to ping the device when it was granted a IP address. Does not respond.

Also tried to hook the device on my laptop (wired). Cannot connect as well.

Today I called WD support, but they don’t have an answer. They say it is my Linksys router, so I gave that one a hard reset and configured it. I set it wide open for all kind of stuff but still no DNS server on my WD live!

:cry:


#5

Are you sure that’s your DNS server? That seems to be the router IP or something.

Try inserting this Open DNS on the Live:

208.67.222.222

208.67.220.220

See what happens.


#6

willynanita wrote:

Are you sure that’s your DNS server? That seems to be the router IP or something.

 

Try inserting this Open DNS on the Live:

 

208.67.222.222

208.67.220.220

 

See what happens.

I believe the poster has already tried that.

My setup (automatic) and via a USB adaptor is:

IP address        192.168.1.5           (allocated automatically)

Subnet mask    255.255.255.0

Gateway            192.168.1.1            (router)

DNS                    208.67.222.222    (opendns on my router)


#7

Most routers that get their WAN address via DHCP will also act as DNS relays;  all of my routers do this.  So, in effect, my default gateway address for my hosts is the same as the DNS server for those hosts.


#8

Hmmm… Still no solution. I have contacted WD and they are going to replace the unit. Hope it is a hardware problem.

If it is not, I will post in this thread again hoping someone can give a solution.


#9

If that fixes it, then I’ll be amazed.   As it stands, that’d be the weirdest symptom of a hardware issue I’ve heard of.


#10

I was also surprised by it, but I really cannot think of anything else… I have tried to connect the media player directly to the modem or directly to a computer but this also does not work. I can’t even ping the media player or access it on IP.


#11

Maybe I’m asking a stupid question but, have you shared the folders/drive you are trying to access on your computer OS?


#12

Yes I have, I am using a MyBook world edition 2TB. This is not my ‘core’ problem. The thing is, I can’t get Internet to work on it! But I don’t know if this problem has anything to do with accessing drives.


#13

Just received a new media player from WD. Still the same problem! I don’t know what to do anymore!


#14

Ok, so when you plug in DIRECTLY to your internet pipe (your DSL or CABLE MODEM or whatever) 

What do you get for your IP / Gateway / DNS?


#15

If I plug in to my modem the automatic (DHCP) configuration does not work. When I set the values manually, the media player does not have a correct connection, not even a correct IP address.

There is one other thing I don’t get: The DNS server is incorrect (that is the problem of this thread) but I have a working IP address. Why can’t I connect with my MyBook world? I am running the twonky media server on it, but if I choose Media Server in the WD screen, I cannot select it. That means the WDLIVE cannot connect with the MBWE.

If I run the Linksys Easylink Advisor, I see on screen when the WDLIVE is connected to the network, but it disappears after a few seconds (offline). I cannot ping the device and the WDLIVE cannot seem to find the MyBook drive with it’s media server running.

I cannot play movies and I also cannot use my internet connection on the WDLIVE. I can’t use it because nothing works at the moment…


#16

I’m guessing you’re using Wireless (EasyLink).   

Does this behavior happen if you use WIRED?   Just for testing?

What kind of signal strength does the WD indicate when Wireless?

An invalid “DNS” will prevent a CONNECTION TEST from passing, but it should not be necessary for viewing LOCAL devices, just internet services.