Inaccessible disk

I have a My Passport Essentials USB 2.0/3.0 hard drive that has worked perfectly up until today.  I am running Windows 7 on a Sony VAIO.  Today, I was suddenly unable to access any of the files on my disk.  When I rebooted, the drive was not recognized.  I reinstalled the driver and tried again, but then the drive was recognized in Computer Management but not in My Computer.  After another reboot, the disk is now recognized in My Computer as (G:/) but not accessable.  I can’t get in.  In Disk Management it says the drive is Healthy, RAW and 100% free.  The drive used to be NTFS and 3% free.  HELP ME PLEASE!

Are you getting any error messages such as Disk needs to be formatted?

Raw means there is some type of corruption. Maybe EaseUS Data recovery work. 


How weird.  I have exactly the same problem (Monday 7 May) that started tonight.  It wants me to format the disk.

What do I do?  I have years of work stored on this, the last 2 weeks of intense resource making not all saved. 

I have now downloaded and reinstalled the SES thingy as it shows on the FAQs on the WD website.  I have also tried the recovery site mentionned in this tread and nada.  It still asks me to format. 

Anyone can advise a non techie user please?

Many many thanks.

      Hi Guys,

   It seems that Western Digital external drives are a piece of **bleep**. As you can see in this forum, lots of people are complaing about the same reason. The external HD just stop working without any reason (the same happend to me). I have one that stopped working after 4 months. Have a look on the topics in this forum.

   Sorry guys, I wish I had somenthing better to tell you. But WD just is not interested in the data we lost and how importat those data are to us.

Try downloading a Linux Live CD and boot from that and see if you can access your data.