Impossible to start my new EX2

Hello there ! :slight_smile:

I just bought a WD MyCloud EX2 Ultra, and I face difficulties trying to setting it up.

First I plug it in and it could not find my internal drive (it’s WD Red 3To, brand new). I could not complete the quick setup and so could not do anything. Which is why I unplugged it. I know it is not recommanded but I really did not know what else to do !

I removed and put back the internal drive. Turned out it was not properly plugged the first time, which explains maybe why it did not respond. I plugged the EX2 back. It starts, and when the Led turns blue the HDD led appears constantly red. I tried lauching mycloud.com/setup and it says that due to power failure, the “files system consistency” (which is litteral translation from french, i do not know the english proper term) is being checked.

So OK I though running a chkdksk (that(s how i understand it) on a 3To might take a while so I just went out. It has been more than 18 hours, and I still get the same message. I do not want to plug it off a second timer, but i simply have no options at all.

Is it natural that this check runs for so long after a power failure ?

I am extremely disapointed that there is no indication whatsoever on the documentation or the wd support website of what happens in case of power failure. At this moment, I have no idea whether everything is going to be OK of if the system is damaged somehow, or maybe my drive was never good at all… And i am pretty scared to try anything.

If someone has some answer that would be a relieve, I hope you guys will know better than me (i am sure you do :slight_smile: )

Many thanks in advance for your time and help.

Hello,

I recommend you email WD support for assistance with this issue.