Impossible to create / access to an iTunes Server

Hello

I own a My Book Live 2to, which works pretty fine (saves have been made, I can access anything from the Finder/Explorer, or remotely from the web or the iOS apps, Twonky works well too…)

My main problem of the day is that I can’t create/access an iTunes Server, especially to access all my music from my Mac Book Air.

On my PC (but it does the same on my mac), the option is ticked in the dashboard, then I click on “reanalyze iTunes” (sorry, this is my poor translation of what the French buttons says), then I can hear the hard drive working, then… nothing. The little window asking me to be patient as the analysis is being done stays and stays and stays forever and nothing happens, and the hard drive doesn’t make a sound, and the green light stops blinking, and nothing appears in iTunes…

I have a pretty large iTunes library (music copied in the Public/Shared Music folder), maybe I didn’t wait long enough ; but I tried for 3 or 4 hours before canceling, which seems reasonable to me…

The other strange issues I have, that might (or might not, sorry for not being very good at all these things…) have a direct link to this iTunes server are : 

  • WD Link can’t see the MBL on the network

  • Bonjour can’t see it either

  • the OSX Airport Utility doesn’t find it either

If anyone has an idea for me, I’d be very grateful…

Thanks in advance, 
Thomas

Hello,

Change the settings back to factory defaults and reset the drive to see if it get’s rediscovered on the network.

Hello

Thanks a lot for your answer!
If I reset the drive and set it back to factory default settings (not sure I changed anything, though…), will I lose all saved content?

(It took me 5 days (x2 because of Smartware, definitely not a good software) to save everything, so if I can avoid this…)

Thanks again, very much!

Hi again,

If you do the factory restore, yes, it will remove the information from the drive. Now, if you are saying that nothing changed on the drive, go ahead and just reset the unit with the button on the back of the unit and the information will remain on the drive.

Bonjour again!

Thanks again for taking the time to try to find a solution for me ; I’m afraid I’ve already tried the “hard reset” manoeuvre, without any improvement…
So yes, I might have to spend another 5 days or more saving everything again after a factory restore!

I tried to call WD this afternoon, the guy I talked to was nice and tried to help, but I’m afraid that each problem we have is so “unique” that they only have pretty vague answers… The tips he gave me didn’t help.

Thanks again for your help ; if anyone passes by and had the same problem but has a different solution to propose, my ears (and eyes) are wide open! :slight_smile:

How did you get Twonky on your Duo?

Hmmmm…
I think Twonky simply comes with the device…
Just ticked the option in the MBL dashboard (Settings / Multimedia), there’s a Twonky server box to tick, and then a button to “analyse” the content of the MBL.
There’s also a sub-menu to chose which devices you want to access the Twonky server.

And if you want to access Twonky’s own dashboard, important for many settings, you can do so by typin http://yourmybookliveIPaddress:9000

I hope this is clear, as English’s not my mother language ; it’s even harder with “technical” things like this!

:slight_smile:

You don’t have a Duo,  you have the single disk MBL.

This forum is for the Duo.

If neither Bonjour nor WD Link can see the drive, it sounds like a network issue.  

Are the PC and MBL on the same network?  Are they both in the same IP Subnet?  Do you have a firewall that’s blocking Bonjour?

Oh dear, my bad, very sorry for the initial mistake…
I was probably daydreaming (that my problem was solved)

 :cry:

The Windows PC and the Mac, every single device I own is connected to the same network/router.
As for the Firewall, I checked that it was off ; it was ON under Win7 but turning it OFF didn’t change anything, and it’s OFF on the Mac.

This invisibility is really strange.

The person I talked to this afternoon at WD support suggested that I give a fixed IP address to the MBL, which I did. No change, but some other devices (PS3) couldn’t connect to the network anymore. So I set the router back to its factory settings.

Thanks a lot for your answer, and sorry again for the Duo / Not Duo mistake…

Hello hello

I might have found something “useful” for my issue, though it didn’t change anything in the non discovery of the MBL by Bonjour (which might not be a problem to set up an iTunes server, as I could set up a Twonky server without any problem).

I understood there might be a difference between an afp connexion and a smb connexion ; I connected the MBL both ways, and now the Finder shows me a “PC server” and a “Mac server” ; I guess this had to be done.

Then I discovered (I know, a bit late) how to use, or how to try to use the “Share” section of my MacBook air settings.
I could add the whole “Network” as a shared folder.
(it won’t allow me to chose individuals sub-directory, such as “Public”)
In the same “Share” setting pannel, I allowed any possible user to write and read (including “all” which makes me wonder if I’m not giving access to my NAS and its content to my whole building… :dizzy_face:)

What hasn’t changed (of course! it would be too simple, and not funny enough) : as I said, Bonjour still doesn’t detect the MBL. I forgot to say that it detects my Denon hi-fi system, which is Airplay compatible.

Now I’m going to try to reboot my Mac and see if there’s any change with Bonjour.

And then I’ll try to set up the iTunes server, and see if it finally works or not.

Of course, all I said here might have absolutely NOTHING to do with my problem! :slight_smile:

Thanks a lot for reading and, if you can, helping!

Thomas

PS : for those who managed to set up an iTunes server, is the “iTunes reanalysis” a looooong process? Does it take more time, actually MUCH more time  than rebuilding the database for example?