I'm unable to update through USB on my WD TV Live wdaapoooonbk Gen. 1?

Hi, I have tried to update my (old) WDTVlive via USB, the present version is 1.06.34_v.

The problem is that each time the device say “the device fails to check for new firmware update, please check your network connection and try again”. I have of course disconnected the wireless adapter.

I have tried several USB devices and the same happend.

So my problem is that the device don’t recognice, nor find my USB.

I have of course also resat the device, unplugget etc. but no luck. 

I remember the I previously could update through the USB so why not now?

Hope somebody can help with solution, sugestions.

Kind regards,


When rolling back, we have to use the rollback version of the firmware, because it has been modified by WD to fool the player into acting like it is a higher version than is on the player.

Also, you will find this msg link important.


You are in the wrong forum. You have an old Live. The firmware on your player is the latest official release. There is a beta release that you can install at your own risk. If you want that you must download the firmware, unzip the files to the root of a USB drive, plug the drive onto the player and follow the prompts.