I'm trying to create a RMA

I am trying to create a RMA, but I am not able to add my address. It says “An error occurred while displaying the address”. I used Chrome and IE on two different computers. I turned off pop up blocker. Is this a problem on my end that I can fix?

Thank you for the help.

Hi Jeff, can you post the link you are using please?



That link isn’t working, but what if you use this one, which works for me?

Link: https://westerndigital.secure.force.com/ind/?lang=en

Oh, sorry, I probably gave the link that was into my account. But I get to the page through the link you have provided and I still can’t get beyond the second page of the Create RMA form. Thanks. I will try again tomorrow.

1 Like

@Jeff_Packer - Sorry to hear you need to create an RMA. Could you send me a private message with the address you are trying to enter? It’s possible that something with the address itself is not being accepted by the system.

To send a private message, click on my username here @Great_Scott and click ‘Message’ (Don’t reply to this directly as it is a public forum)

If you can’t wait, you can also contact support (they can assist you with creating the RMA) by calling the number for your region in the link below. If you do, we’d still appreciate you providing us with the address (you can change some of the numbers if you are concerned about security) so we can investigate why the error is occurring.

1 Like

@Jeff_Packer - Thanks for sending us the address. I sent you a private message with some additional information.

Hey !

I’ve got same problem here … And I can’t use “Message” feature, because there is no something like that after cliking your profile name ;(

Hi @Patryk_Nieborak - What browser are you using? The message button should appear… For example when I click on your user name I see the following:

Thanks for your fast reply.

I’m using Chrome in version 46.0.2490.80 m (64-bit).

I tried also on Internet Explorer - same problem ;(

That’s how it looks like after clicking on your profile:

Maybe I’m not able to send Messages, because of new account or unproper settings (I checked options of my profile, I don’t see anything about this) ? I wanna add, that I can normally receive messages from tracked threads.

That is… odd… Do you see the button for @Bill_S ? If so go ahead and send him the address and he can forward it so we can investigate.

Private messaging can only be done when a user achieves trust level 1. This is for spamming purposes. You are still at trust level 0.

Trust Level 1 Requirements:

  • Must enter 3 topics (I just changed that from 5)
  • Must read 30 posts
  • Must be in the community 10 minutes

Thanks guys for help. Now I’m able to send Messages :wink:

@Bill_S PM is coming :smiley:

i just tried 5 minute ago, No change, is still rejecting the singapore address complaining “An error was encountered while saving the address.”

If we are not able to go through the form, how can we create an RMA. getting frustrated

I really hope WD as a huge company get the basic fix

I am having the same issue as well. I am trying to add a California, USA address and it keeps giving me an error. I’ve also tried different browsers and different address to make sure it’s not just one address.

Anyone else have this issue?

I am having exactly the same issue.
Can someone please suggest a fix?

I phoned support (UK) and completed my RMA over the phone. I reported this (and other issues - ie. could not update my profile, help (site) could not be displayed). He said he would pass it on.

Hope this helps somehow.

I am having the same issue

To clarify, you’re having a problem creating an RMA online? Can you give me specifics?

  • What part of the process is hanging on you?
  • Where are you located, country?
  • What browser and OS are you using?
  • Oh, and can you give the link to the page you’re creating the RMA from?

I am having same issue. Does not add my address (Germany) but displays an error message