I'm having major problems


#1

I purchased a WD media player yesterday, seemed to fit my needs. I hooked it up without a problem to a 200gb hd i had, seemed to work fine. When I hook up a WD My Book 1tb hard drive, it dosen’t get recognized. Also I tried to use my USB wireless adapters (Netgear and Cisco) on it and I don’t get any signal, when I hard wire it, it seems it work fine. My HD TV is too far away to hard wire so that’s not an option. Is any USB adapter OK or do I need a certain Brand? Do I need to download something to get it to recognize the “My Book”? Any help is good help!


#2

Welcome to the forums.

You must use a USB adapter that is on the approved list – a search of this site will reveal the supported adapter sheet (also make sure you note the firmware version, as even approved adapters only work if they are the right firmware version).

I can’t help you about the drives – some work, others don’t but I would think a WD drive would (someone else will answer that for you).


#3

Thanks for the response,I have the list of compatible usb adapters, is there a list of hard drives ?


#4

Not that I know of but make sure you do a forum search here to see if this drive has had any issues (or not, if someone is using it successfully).


#5

ludendorf wrote:

Thanks for the response,I have the list of compatible usb adapters, is there a list of hard drives ?

That same list has a list of known-good hard drives.


#6

I initially had the same problem with my WD TV Live not recognizing my WDElements 1.5TB drive I had purchased sometime ago.  I reformatted the drive and the WD TV Live now recognizes it without a problem.  Have you tried reformatting the drive to see if that works for you?