(!) I'M DONE WITH THIS RIDICULOUS PRODUCT (!) / how to contact WD and get money back?

I don’t believe that I’m using this forum for exact same reason after a year has passed…

Dear WD,

I bought Your product year ago and was more than happy with the purchase for… 2 days. After 2 days I’ve started to have problems with logging in the dashboard, accessing the drive in the Network devices etc etc.

After 1 month one drive failed and I was trying to get the RMA but unfortunately in the middle of my e-mail conversation with Your tech support (which took smth like 2 weeks) You decided that You won’t tolerate other languages than English any more so we had to create another RMA in English and start the process from beginning. Your tech support couldn’t understand this, neither couldn’t I.

At the end of the process Your tech support told me that You will wipe out everything from the disks, not just one disk, so I need to copy 4TB of data somewhere else before sending You the WDMyCloudMirror. I asked if there’s a possibility that I could pay You for copying the data but that wasn’t an option. Unfortunately what I also found out were the prices of buying new disks JUST FOR THE COPY (small external WDs) or copying the data to any kind of Cloud server or using any company to store the data for one month. The prices were the value of new WDMyCloudMirror. Unfortunately at this time I had no money on my credit card so everything got stuck.

Ater one month I contacted Your tech support because I had an idea! “Is it possible to send You only the failed drive?” - the answer was “Yes”… Bravo WD, bravo!

Still, I found another way to copy my data and decided to sent You complete device.

After another one month I got it back. In the meantime You decided that You will produce new model but I received my old one (7 months old) with one new disk. Turned it on, copied all my data to it and forgot about it because of my health problems I had at that time (there are more important things in life sometimes than fighting with some capitalist, You know?).

TODAY I wanted to copy new data to it. Plugged it in the power outlet, everything else was the same as I left it and… bam!

  • Can’t wake the device from WD Quick View, it stays yellow.
  • Can’t access the dashboard by WD Quick View.
  • Can’t access the dashboard by wdmycloudmirror.local.
  • Can’t access the dashboard by IP.
  • Don’t see the device in Finder. After I mapped it it shows on SMB connection but even if I get inside the folder I still can’t access the dashboard or access the drive from another computer.
  • After I turn it off and on again and connected through Ethernet I could access everything as in the past so I tried to create FTP for it BUT then I found out You can not connect through the FTP if You are not in the same network, which is ridiculous.
  • After I unplugged Ethernet cable and wanted to access the WDMyCloudMirror again by the WiFi I got green light in the WD Quick View this time BUT everything went even worse. Now I have WD Quick View menu for my device but I can’t open it and can’t access the dashboard and ALSO my device disappeared from the Network. I mean, disappeared permanently, I can’t map it again.

After I spent another 2 hours of my life with Your stupid product I wanted to create tech support submission BUT I’m not able to do that since my product is registered in polish language and if I want to create new submission Your site tells me to change the language. If I get back to the WD website and change it to english and then click small support link (another farce) and then find another small link for getting back to the tech site (because the big product icon doesn’t link to it…) IT CHANGES TO POLISH AGAIN so I’m still not able to create new tech support submission. Farce.

When I decided to contact You by e-mail or phone and clicked the big #$@#$ “Call WD Support” or “Email WD Support” it showed me that I can’t contact You by any of these ways because none of these are accepted in my country.

Also when I wanted to write this post I found out that I put wrong e-mail at first and now WD wanted me to create new account. I didn’t want to create new account since I have this one but I couldn’t log out because You don’t have $&$#&@*$ “Change account” button on this ridiculous little window. So I had to clear cache of my browser and restart it to log to my proper account…

For God’s sake, I know the net-worth of this company. How is it possible that You make such money with such products?? Your forum is FULL of cases and You did nothing for the last 3 or 5 years with it.


P.S. I could show You the little screen recording with all these ridiculous bugs Your developers make but I did it after throwing my mouse out the window so I think You won’t like to see it if You consider number of vulgarisms I throw at You…

Ok, WD contacted me via e-mail. Will let You know about the progress of the issue.

Hopefully WD Support will be able to address your concerns.

Will find out.

The new info is while writing the e-mail to WD support I discovered that while I’m not able to connect to the device via wdmycloudmirror.local, I am able to connect to it via it’s ip address which you need to find by IP Scanner app (for example).

The WDQuickView still shows yellow light though.