Ignore directories not working

Apologies if this is answered elsewhere bu I’ve tried everything.

I had successfully added ‘Shared Music’, ‘Shared Videos’ and ‘Shared Pictures’ to the ‘Ignore Directories’ comma-separated list in tthe Twonky Server. They had stopped appearing in my Public share.


Then, as I had not turned off auto-updating of firmware at this point, the firmware went off and updated itself and of course, reset all my settings (great feature btw Twonky/WD :angry:). I have rectified that but now if I add Shared Music etc. to the list, it appears to be having no effect at all and they keep appearing in the Public share. I’ve even tried editing the twonkyserver.ini file through SSH, also to no effect.


Any clues what I’m doing wrong?

This is what the Ignore Directories list looks like:

Shared Music,Shared Videos,Shared Pictures,AppleDouble,AppleDB,AppleDesktop,TemporaryItems,.fseventsd,.Spotlight-V100,.Trashes,.Trash,RECYCLED,RECYCLER,RECYCLE.BIN,Software,_WDPROT,.wdmc,.wdphotos,

Twonky creates the ‘Shared media’ directories, I’m afraid, so you’re stuck with them. The best I managed to do was consolidate then into a single folder. See my FAQ:


Yes, but I had successfully ‘hidden’ them from browsing views using the Ignore Directories options in Twonky (on your advice incidentally!) but now it seems not to be working.

Why would a directory in the Ignore options still show?


Then I guess that the shared library must override the ignore directory list…

Looks like I was wrong to hope that would work.

Do you actually have media in the ‘shared’ folders? I don’t, and that may be why I don’t see these folders in UPnP client apps. As I said in the FAQ, I think the ‘shared’ folders are intended for Aggregation, but the documentation says you should use them to store media, even though doing so caused me no end of problems. Do you have Aggregation enabled?

But you had it working okay before the upgrade?

Have you checked the Media Serving and Media Streaming controls are set properly?

One other thing you might try is just using the single word ‘Shared’ in the ignore list, as I think that list might be a sub-string search (which would be problematic), and I found spaces in paths to cause trouble.

Have you tried changing the share directory names in the .INI file?