Idiot's guide to making WDMyCloud work - needed!

Hi there.

Just bought my WD My Cloud and like many on here am experiencing unstable performance. I’ve read up on SHHing into the drive and think this is what I’ll need to do but have some questions. First, my set up.

MacBook Pro 2011 running OSX 10.10.4

WD My Cloud 4TB

Virgin Media Superhub (with Virgin Media TiVo and Ps3 connected)

I’ve got less than 1TB of data at the moment. Have got about 300gb of Aperture libraries, about 800 short movie clips in folders and other media. I want to use the device as follows:

Store all my media and access from my MAC. Remote access is not essential.

Stream my video files via the Ps3

Back up to the device using Time Machine

Create a safepoint either using my old Seagate GoFlex Home as a NAS or sticking it in a USB2 caddy and connecting to the WD device.

I’m not interested in using the photos app. In fact, I’ve got my Aperture libraries on my persona share with media serving off. The only share I’m using to stream is ‘video’. I don’t need to see thumbnails of the videos on the Ps3 as they are all titled.

The issues I’m experiencing are as follows:

Drive sometimes not being available to connect to when trying to connect through dashboard icon - WDMyCloud - Open

Can’t copy over a 70GB Aperture library as it either says it is going to take 50 days or then suspends the transfer saying there was an error (sorry, forgot to write the error code but it’s happened a few times)

Streaming on the PS3 works sometimes but is very slow and videos get stuck regularly OR it tells me there are no files. Am also getting a Media Server error 2006 (thought I have tried to address this as detailed below)

Scanning never completes and drive is very sluggish

I’m connecting via ethernet when I do the file transfers and the lights on the device seem ok. Have only unplugged a couple of times when I first got it but since then have been able to power down or reboot via dashboard. I’ve set the PS3 up in a DMZ (I think!). Have turned on DMZ in the Superhub and given it the IP address I created on the PS3 and it connects fine. I still get the odd 2006 message though but I do also have NullRiver MediaLink streaming from my mac enabled so that might be causing the issue.

So I think what I need to do get this working is to disable the scanning that takes place to create thumbnails? I think there are other processes that are suggested to be stopped but I’m not clear on what they are or if I need to do them.

My questions focus on the required steps. I’ve never used Linux before and am always anxious going into Terminal. I don’t want to screw anything up and am hoping someone can guide me by speaking a language my mother would understand! I know how to turn on SHH through the dashboard and that is about where my knowledge ends. I know this has been covered before but in every post there is at least one bit of info missing that makes it hard for people like me and my mother to understand! Eagerly awaiting some guidance. Thanks all.

First thing to do is to assign a fixed IP address for your MyCloud. With the virginmedia hub it is best to disconnect your WDMyCloud from the network first and re-boot the hub. Before you disconnect it, make a note of the MAC address for your MyCloud. Then follow this guide to set up your router.

This will prevent your router from changing the IP address of your MyCloud and disappearing off your network. 

Once you have a stable MyCloud you can disable the scanning services following this guide.

1 Like

The procedure for SSH into your MyCloud is easy as long as you are careful you should be OK. Follow these instructions:

  1. Enable SSH
  • login to your WDMyCloud dashboard ( http://wdmycloud/ ) -> go to Settings -> Network -> and set  SSH to  ON
  1. Download Putty, an SSH client​download.html

- install it on your computer

  1. Open Putty and connect to WDMyCloud via SSH
  • Enter the IP address of your WDMyCloud in the  Host Name ( or IP Address ) field.

  • Click Open on the bottom to connect

  • If this is your first time using SSH for your device you will need to accept the  Host Key by clicking  Yes

  1. Login
  • The default login is “root” and the password is “welc0me” (yes, that is a number zero in welc0me)

Run the following commands

/etc/init.d/wdmcserverd stop

/etc/init.d/wdphotodbmergerd stop


update-rc.d wdphotodbmergerd disable

update-rc.d wdmcserverd disable

That’s it, you can log out now (type “exit”)

You may now set the SSh back to Off in the MyCloud dashboard

Note: Copy and pasting commands with putty can be done by selecting the commands from this screen (copy),

then go back to the putty screen and paste by right-clicking on your mouse anywhere on the screen.

1 Like

An easier way to stop the processes is to use the /etc/rc2.d/S98user-start script.  This file is a symbolic link to

/CacheVolume/user-start.  Currently this file is empty.  All you have to do is put statements to stop those

process that you want to stop.  Every boot this file will be run.  No need to update-rc.d.  You don’t want

to stop the scripts then rename the user-start file to another name and reboot.


PS Does it violate the warranty to do the update-rc.d?  The S98user-start was put there by the


1 Like

Dubie. Thanks. It worked. Things seem to be ticking along nicely. RAC, thanks also but if already followed Dubie’s guidance. Also, whilst I totally get what youre saying, my mother got a bit lost. Not me though. Just want to be clear about that. For my mother’s benefit though, is there an advantage to your proposed method and should I be undoing what I’ve done and following your steps?

congrats fenechy… it is better to get the community to chime in then trying to get help privately. This way everyone benefits plus it saves me a lot of typing :stuck_out_tongue:

I think this post should be stickied!!

1 Like

It dosen’t matter which way you do it.  But to undo it you need to do the enable to get it back.

I just think it is a cleaner way to do the changes. 


1 Like

Hi RAC, can you give a step by step instruction (dummy’s guide) for the steps you recommend? That would be great for us novices

Oh, and if anyone can tel me why this forum auto-allocated me a green swamp monster as my profile pic that would be great too! :neutral_face:

Hello Fenechy, 

The avatar can be changed from the settings tab under your profile.

You can access your settings by clicking on the My Settings tab upper left side on the Community next to help.

Once you access the settings, you will see the option that says avatars and it will allow you to upload your pic or select a different one from the multiple collections.

1 Like

do the following:

ssh to the My cloud

cd /CacheVolume

vi user-start

/etc/init.d/wdmcserverd stop

/etc/init.d/wdphotodbmergerd stop


You need to type i for insert then type your lines

Then press esc key followed by :wq enter key  Don’t type the <> characters.

The next time the system reboots it will execute these commands.


Hi guys,

Tell me if I should start a new thread here but I think this fits as a logical progression. Firstly, my drive has continued to work in a realy stabe fashion following the advice on this page. Until I tried to set up a safepoint that is! I’ve takent the 3TB drive out of my old Seagate GoFlex Home and put it in a USB2 cady. Managed to repair and format it and eventually got MyCloud to recognise it. Set up a safepoint and that is when I lost connection to MyCloud. Not completely though. I can access the folders through Finder with no problem but I can’t launch dashboard or the MyCloud App. I guess this is because it is busy copying over the 1TB of data stored at the moment but I want to know if this backup is really happening. The way I’ve been checking is to select the backup file through Finder and looking at the file size through ‘get info’. The safepoint backup has been running for about 24 hours now and the _WDPROT file says it is taking up 33KB on the disk. That seems slow surely? I’m thinking I need to reboot but don’t want to pull the plug ideally. Can I power-down through Terminal and SHH? Also, if I do I think I read somewhere that I should disconnect the USB drive before powering up again to avoid thrashing?

Any advice welcomed.


 USB port is simply very slow. I measured 3.4 MB/s.  You should be able to estimate how long it might take to back up your data; 3TB would be about 10 days at that rate…

Thanks for the reply. I’m still stuck on 33KB so there is clearly an issue. Any way to power down the drive throught Terminal?

Hi again. I managed to powerdown using ‘sudo powerdown’. Not sure if I needed the sudo bit or not. Anyway, I have still been having issues with the safepoint and my Seagagte GoFlex home as the destination for that safepoint. I noticed a firmware update today saying it added stability to safepoints. Downloaded and installed all ok. I have 2 questions though:

  1. Will the update have undone the setting changes I applied from the earlier solutions in this thread? 

  2. Could the update be responsible for the folowing message I now get when trying to log into ssh:





Someone could be eavesdropping on you right now (man-in-the-middle attack)!

It is also possible that a host key has just been changed.

The fingerprint for the RSA key sent by the remote host is


Please contact your system administrator.

Add correct host key in /Users/fenechy/.ssh/known_hosts to get rid of this message.

Offending RSA key in /Users/fenechy/.ssh/known_hosts:1

RSA host key for has changed and you have requested strict checking.

Host key verification failed.

Oh, and question 3 is whatever the answer - how do I sort out the above??

if you are using only one ssh server you can delete the known_hosts file on the mac side

start up terminal


rm .ssh/known_hosts


or if you ssh into multiple ssh servers you only need to delete the one offending line in that file


cd .ssh

vi known_hosts

cursor youself to the line that contains your cloud server name and use “dd” to delete a line


then type the three characters


Good luck…

1 Like

Thanks Ralphael. And will the changes I made to the mdeia scan settings stil be in place after the firmare update or do I need to do that again?

It is a fresh new linux OS on your device and you will have to issue all those stop commands again.

1 Like