Icon missing

Hi every one. My first post here.

A few years back I purchased, a 2TB WD my book for my Imac. All has been working well untill a few months back when the icon on the screen to open my book dissapeared. I have downloaded an update, but still no go.

I am running out of space on my 2007 imac, and I have a stack of stuff I need to check out on the hard drive.

The numbers on the rear are:- E101559, part number WDBAAG0020HCH-02    5112B.

I still have the face with the two cogs inside it in the blue icon on my bar, but this only brings up the SmartWare, and I am unable to enter from there. The HOME and Settings tabs I can access, but the Back up and Retrieve tabs are a no go.

Can anyone one help here please.



I recommend you try some basic troubleshooting:

1- Connect  the power adapter to the wall directly.

2- If the computer is a desktop, connect it on the back USB port (directly to the computer, not through a hub).

3- Go to "Disk Utility” to verify if the drive shows up there.

If the drive shows up in “Disk Utility” but it is not seen on Computer, then it means the partition is corrupted and you will have to format it in order to use it again. Please note that formatting the drive will delete all data stored on it.

Thank you for your reply. I have the unit directly connected to the mains, and to the rear of the computer, so that has the first two covered. I have not tried the third one, for it never crossed my mind, I am not computer literate in that way, however I will try that as soon as I am able.

Thank you once again


 Icon “Smartware” is missing after installing my new 1TB WD My Passport Ultra external harddisc.

So I can not open the Smartware program. The other 2 icons(Security & Drive Utilities) are there.

I did a restart, and a re-connect but the Icon does not show up. It did make the auto-backup.

I have Windows  8.1

Thank you for your help.