I sure would like to stream my media, but WDTV is failing me

First off, the remote was DOA, I’ll be dealing with that separately. If anyone has any solutions for me, please keep in mind I’ll only be able to type onto a keyboard that I attached to the WDTV.

  1. When I plug an external hard drive into my ASUS N66U and have it serve the files to the WDTV, then WDTV will only see 24 of my 300 files. Alphabetically these are the 1st 24 files on the network drive. This is my preferred method of getting WDTV to work and it is a real disappointment that this does not. I have tried to delete a hidden “wd” file somewhere on that external drive (suggested by someone somewhere), but this file does not seem to exist on my drive.

  2. When I plug the external hard drive into my computer, and serve via Plex, then WDTV DOES see all 300 files. However, most of the time it will not stream any of them and simply shows the swirling “please wait and wait” symbol. Keep in mind the WDTV is located a mere 15 feet from one of the best routers available.

  3. When I plug the external hard drive directly into the WDTV, it does not recognize it at all. One time, however, it did say it was “scanning the USB drive” or something to that effect. Then it stopped a few seconds into it and I have never seen it mention that again, even after turning the drive off and on and also unplugging it from the WDTV and plugging it back into the WDTV.

My current firmware version is 1.15.10. It says that a newer version is available, 1.16.13, but when I try to update to that (after about 30-45 minutes), it just goes back to the main WDTV menu where I can see that it is still version 1.15.10.

I’m really frustrated and at the end of my ropes. I have no more moves that I can think of to resolve this.

When you have your hard drive plugged into your router and it only sees two dozen folders, are you able to see the all 300 files from your computer?

If you can see all 300 folders on your computer but not the WD TV, then it is a rights/permission or sharing issue with the folders on the hard drive connected to the router.

Check the properties and sharing information for a working folder and compare it to a folder that isn’t working.

When you are connecting with the WD TV to see the movies on your hard drive connected through the router, you are clicking into Video, then you hit the Red button (if you have a busted remote then you have to connect to the WDTV from your computer, unless you have a shortcut key for the red button, to use the butttons on the remote open a browser and goto http://wdtvlive/ then login using the username admin)

After hitting the red button, select Network Share and Chose Windows Shares, then select the hard drive that your router is sharing.  It does show your router connected hard drive as an option right?  You are sharing it as a drive your computer is sharing, right?  It’s not being shared as computer share, but through your router, is it?

If it still only shows the 24 folders, then it has to be a sharing or permissions issue.

Hello. I understand your pains. I have had this device for a couple years now. I can share with you info about the external HD, which is how I use the device.
I will assume you are using a USB 3.0 drive. Unfortunately, this does not handle 3.0 well. SW version 1.15 is really broken in this area. If you roll it back to 1.13 or 1.14 it will scan and find all of your media. It does, however, choke every now and again, causing you to reboot the drive and media player. If you have a large library, this could take a while. Do a search to find the instructions, it is easy. DL the file from this site, then put it on a thumb drive, insert it into your media player a d it will recognize it and load that version.
I see that they released 1.16. I haven’t tried it yet. The release notes do not mention anything about USB 3.0 support, so my hope is low.

There are many missing pieces of information in the original description, which make it difficult to provide assistance.

E.g., How exactly are you having the ASUS router “serve files to the WDTV?”  SMB?  NFS?  DNLA?  I am not going to go track down a manual for the router just to try to figure out what you might be using.  Makes a difference.  If you are using SMB and you can see only some of the files on the drive, that very well could be the router’s fault or could be an issue with the files on the drive.  The notion that the ASUS is “one of the best routers available” so it couldn’t possibly be at fault is not a useful nor realistic point of view to take when trying to diagnose problems like this.

What filesystem are you using on the drive?  Is there anything different about ownership/permissions among the files?  How the the files organized on the drive?  All at top level, or in directories, etc.?  What format(s) are your files?

You can see all files when the drive is plugged into your computer.  What OS is that computer running?  If Windows, then why not try sharing out the drive and try to connect that way.  Plex is a DNLA server, so you now you are introducing yet another component into the chain to play things.  E.g., DNLA doesn’t work with .iso files.  Much better to simply share out the drive.

The drive doesn’t work when plugged into the WD TV unit.  What kind of drive?  USB 2 or 3?  Have you tried both the front and rear USB ports on the WD unit?  Again what filesystem is on the drive?  Have you run a disk checkup on the drive from your (Windows?) computer?  Linux-based systems like the WD units generally won’t mount NTFS filesystems that are marked as being inconsistent.  Can you see and play all files on the drive from your computer?  (Drives fail all the time, so don’t just assume it is fine.)

There are lots of things that might be tried, but much more detailed info would be required to make more suggestions.

I also have a RT-N66U, and a hard drive connected to it, although it has no media on it that I want for the WD player.  It is a duplicate of my music folder and a few other things, but this data is already on drives connected directly to the WD player…  I only recently put this drive on the router.  So, after reading this thread I went to my WD player to see what’s up with it and the router drive.  It showed up in both the Media server and Network Shares menu.  I could see all the data in Media server, but got a message that there was no media on the drive from WD when looking in Network shares…  (Huh?)

OK, so I looked in the router settings and set up “Set the account and permission of network place(samba) service”.  Not a good idea, because things on the PC got screwed up from there; I could not access the router drive from PC, etc.  I ended up resetting my router to the defaults and setting it back up! – very carefully.  Bottom line, all is working fine again; both my WD players see the data on the router drive via Media server and Network shares. I did NOT go fiddle with the router any at all this time other than to get it all working again as before.

The point of this story is:  If I had just rebooted things and not “panicked” that there was a problem, it all would have likely been OK…  Another point: the less we fiddle with these things the better!

Anyway, your WD really should be able to see all the files on the router’s HD like mine does.  Maybe you, too, fiddled with too many settings in the router or somewhere else.  If all else fails, reset the router back to the default, and when you set it up, make minimal changes other than what is necessary.

Another idea: maybe you don’t have a defective remote – maybe the player is defective in that it does not respond to the remote.  If you have a friend with the same player, see if his remote will work with your unit.  If it doesn’t, I’d say the player is defective.  You just might want to return and exchange the unit if not too much time has passed.

Last thought:  I don’t think the best place for a HD the WD accesses is on the router – the best place is attached to the WD itself.  I have two 2TB drives attached to mine.  But, I can also access the one on the router, the PC’s, on the other WD player and even the Pogoplug drives.  I consider all these, (other than the WD-attached drives) as nothing more than a “bonus” I can access with the WD, because a direct connection is always better than a network connection  – wired, and especially wireless.

Oh, and one thing really nice about a drive w/media content attached to this router is that the router then becomes the Windows master browser and stays that way as long at the router is on – which is 99.9% of the time.  Master browser issues are a thing of the past for me now.

Anyway, my system is back to normal, and I hope you get yours working, too.