I signed up for this forum just so I could Post


#1

I have a My Book Essential. It worked for about 4-5 months. I backed up all kinds of important files on my network (it was usb connected to one of three PCs all running XP Pro).

One day, I no longer see it as a drive listed as one of my network places. So I try it on all three PCs. I hear the “ding”  (as if each PC knows I connected a device)… but nothing. Drive not recognized.

I scoured the Web for solutions: a shorter usb cable,  installing WD SMartware, etc. and so forth. Now I scroll this forum and all I see is 100s of people with the same problem.

The drive isn’t a year old (I’m sure it’s still under warranty). Now I can’t get to all my important files.

BUT HERE’S WHAT I’D LIKE TO SAY: AS more and more companies sell garbage, and those same companies have subpar customer service that is mostly handled via “email only” support questions that are then answered autonomously with a generated form reply…   WD IS THE WORST! Hands down!!! The problem I (and countless others) are experiencing with WD external drives not being recognized is UNACCEPTABLE. Shame on you WD…

I’m not about to call one of the WD service #s only to get caught in a automated maze. Or if I do get a live person I can only imagine what the cost will be for WD’s “stellar service plan.”

I will be sending this useless drive back to WD (if WD has the balls to list its address on this site). And yes, there will be an angry letter (worse than this post) enclosed with WD’s Bushleague drive.

I won’t hold my breath waiting for a working drive to be sent back either. You can toss the drive in the huge bin where all the other nonworking externals get dumped to be sent back to China. And, maybe the included letter might make it onto the desk of an incompetent manager with a corner office. But I doubt it.

So, if the underling who opens the returned drive and the included letter, he or she can simply wipe their **bleep** with it.

RAF


#2

Dude, what have you tried to bring the drive back to life? Did you check disk management (Instead of device manager)? Did you try a firmware update (It works 70% of the time)? Did you try a data recovery software?

I know you’re upset, but you won’t know if the drive can work again until you try… o.o