I see MBL in Chrome & Explorer but WD SmartWare doesn’t!

I recently upgraded my cable modem/router. WD SmartWare (1 Win10 PC and 1 Win7 PC) and my MyBookLive worked perfectly with the old router. I plugged the MyBookLive in to the new router and
1- I can browse to all it’s files by running the command (or in File Explorer) \mybooklive
2- I can browse to it’s webpage to view it’s status by going to http://mybooklive/ in MSEdge.
3- the webpage says the status is good!
4- the light on the front is green!

However, when I try to open WD SmartWare to see if the backups are running… WD SmartWare can’t see the MyBookLive anymore… ON EITHER COMPUTER! I called the cable company and they said there is no sort of port blocking or anything that is any different between my old router and my new one. I looked everywhere in the router’s config page and there’s no sort of firewall or anything between the WiFi and the ethernet ports. (I even tried plugging my PC directly in to the router. The internet worked but still couldn’t see the MyBookLive in WD Smartware.)

I tried uninstalling and reinstalling a bunch of times. I remember this happened before and it took a very specific sequence of reboots, uninstalling, reinstalling, etc etc… to get it to show up in WDSmartWare.

Any thoughts? Please help! I’m flying completely unprotected right now!! No other backups!

EDIT: I tried WD Discovery… it told me this. isn’t this a slap!? LOL!:

Unreal. No clue how this was so hard to find. When I installed my new router, I renamed all my WiFi network names to the same SSID and Network Key as the old router (so all the stuff in my house would just automatically connect to the new router and I wouldn’t have to reprogram every single thing in the house). My Windows 7 and Windows 10 PCs must have realized it was a different router so created a new network profile or something because it now saw my home network as PUBLIC. Once I changed it to PRIVATE, bingo the drive showed up. HOW IS THAT NOT NOTED ANYWHERE EASY TO FIND THAT, IN ORDER FOR WD SMARTWARE TO FUNCTION THE NETWORK PROFILE MUST BE SET TO PRIVATE/HOME!?!?

Click on your wireless network icon in the system tray then click Properties:

Then set the Network Profile to PRIVATE!

See the post half way down from pokeefe on Nov 17


Just be aware that on some very rare occasions - such as if you get a new router - Windows will redefine your network connection as Public and you will have to got through this enabling process again