I screwed up my MBL DUO 6TB software, need help fixing

Okay I shouldn’t have been messing with the software, but it was just so tempting because I’ve been doing a lot of server work on a Debian server, and when I discovered MBL is running Debian I just couldn’t resist adding features. I started out with adding a few simple commands like ftp and screen. (Screen and a few other commands are really useful for moving files directly from one MBL to another without running the data through your computer.) Then I began writing PHP scripts (I do a lot of website design) and ended up writing a whole suite of very useful tools. Then came the straw that broke the camel’s back. I wanted to write a PHP script to unzip an archive (no problem) and downsize the images to lower resolution, then zip them back up in a new, smaller zipfile. But I ran into a problem, the MBL’s PHP didn’t have the php5-gd (graphics) module I needed. I had to add another archive to my apt-get sources.list to get a repository that has the module.

[QUOTE]deb http://packages.dotdeb.org wheezy all
deb-src http://packages.dotdeb.org wheezy all[/QUOTE]

Needless to say, things went poorly. Now I have some unresolvable dependencies and can’t figure out how to resolve them. Here’s the last part of the install process:

[quote]dpkg: warning: files list file for package ramlog' missing, assuming package has no files currently installed. dpkg: warning: files list file for packagelibparted0’ missing, assuming package has no files currently installed.
(Reading database … 19458 files and directories currently installed.)
Preparing to replace dpkg (using …/dpkg_1.16.16_powerpc.deb) …
Unpacking replacement dpkg …
dpkg: error processing /var/cache/apt/archives/dpkg_1.16.16_powerpc.deb (–unpack):
trying to overwrite ‘/etc/logrotate.d/dpkg’, which is also in package wd-nas 02.50.00-142897
Processing triggers for man-db …
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)[/quote]

I had fixed a couple of missing deb keys etc. but in the end I have some missing dependencies and Apache won’t run. I’ve spent 4-5 half days working on it and I’m practically ready to give up (i.e. get a bigger hammer).

First, if anybody knows how I can fix my missing dependencies problem I’d appreciate some advice. I really wish I could get that php5-gd module in, but I’d settle for restoring my MBL DUO back to the factory Debian configuration.

If I can’t get any help on that or get help but it doesn’t work out, what do you think of my alternate plan?

I have like 5 MBLs, four of them DUOs in RAID config. Right now I’m moving files off the problem MBL to other MBLs and intend to eventually have all my user data moved to other MBLs. I have my most recently purchased MBL which was almost empty so I’m clearing it off to other drives too.

Both the new MBL and problem MBL are 8TB DUOs set up as 4TB RAID. I figure if I get both the problem one and new one empty, I have two equivalent drives except the software in one is messed up. So in the problem drive I remove the HDDs and format one HDD (or maybe just remove the partitions to turn it into the equivalent of a virgin drive). Then I put it in the problem MBL and remove a HDD from the new MBL and use that as the other drive, and then presumably it will rebuild the formatted drive and come up running with the same config as the new MBL. Then I remove the new MBL’s HDD and put it back where it belongs, format the other problem HDD and put that in the problem MBL and let it rebuild again.

Unless my theory is wrong I should now have two identical MBL DUOs and all I have to do is leave one powered down while I change the IP address etc of the previously broken one back to its old settings. Then I power up the new MBL and if all works okay I should have two MBLs with identical configurations (except IP address etc) both empty, and I can move my files back to the previously broken MBL and I’m good to go.

So (1) can you figure out any suggestionss on fixing the config of my broken MBL? Or (2) do you think my scenario of rebuilding the broken MBL off a working MBL is a good idea?

Hi there,

I have not tried this, lets see if another user can share some information or tips on this matter, also you can check on this thread see if you can find something that helps:

Thanks for the link to the other topic. It’s going to take me quite some time to analyze the procedure. I even have some of the tools, and better, I have a Debian desktop so I don’t need to do anything using Windoze. I am somewhat concerned that a brief read appears that I may need access to the MBL’s admin page, and if so that will be a big problem since due to my PHP missing Apache won’t run either, so there is no way to get access to the MBL except via ssh. However I’m being pessimistic and after reading the above guide until I fully understand what they are doing I won’t know if I have all the access I need.

I think the biggest problem is the wd-nas 02.50.00-142897 package, which I presume has WD’s basic custom stuff for their control panel etc., and the necessary basic stuff to get it up and running. That is where one of my problems comes from that it has a duplicate of at least one package on the Debian package server.

It’s going to take me most of the day to move all the data to other drives so I’ll have plenty of time for research. And fortunately most of the work moving the data involves issuing the scp command via ssh and then hours of watching data fly by (actually I’m not really watching it as long as the lines are flying by when I check in now and then). It may take even two days to move it all. Can you imagine how long that would take if my PC was involved instead of moving data directly from MBL to MBL using the MBL’s to talk to each other directly? That’s one good reason to get into understanding Debian and Linux commands, because there are things you can do quickly via ssh that could take hours if done from an attached PC and Samba. For example, no problem to move a share from one MBL to another using scp or wget.

At least I think my ultimate fallback procedure seems very likely to work since it’s equivalent to rebuilding after replacing a failed drive. Since writing the OP I realized it might be better to take a drive out of the failed MBL, delete all the partitions using my Debian desktop, and then that should make it the equivalent of a virgin HDD. Then put it in the working MBL and let that MBL rebuild the erased drive. Once rebuilt, I wipe the other drive and put the two of them back in the failed system, rebuild again and I should end up with a working MBL. Then all I have to do is resolve the IP address duplications and I’m good to go. (Except for a lot of moving data back.)

Just a bit of errata: I don’t know if I can change my post title but both units are 8 TB MBL DUOs. But that really doesn’t change anything.

By the way, forgot to add, once I have ALL my data moved off the problem MBL, that will allow me to take much more radical chances shuffling packages etc. I sure wish it was my 3TB non-DUO MBL that was screwed up. I’d just use my desktop to copy the data to another MBL and then turn the 3TB single inbto a web server.

To be honest I’m not at all thrilled by MBL’s DLNA and Twonky and MediaCrawler and the whole thing. I’ve got the WD TV and the interface is so goofy I can’t really get any good media experience. It’s a good thing I bought my MBLs to use as part of my home data center and 99% of my interest was just the NAS part, not the media server part. In fact I have all the media stuff turned off on all the DUOs except for the 3TB single.

Just to update, I’m tempted to run the debricking procedure that keeps your data, but a recommended step is to backup your /shares. I think WD must have changed the file system because Diskinternals Linux Reader does not read the partition /shares is on.

Actually if I could pull off my ./shares data I think the rest would be easy.

:smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley:

As you can tell, I solved it! I used R-Linux. While primarily a recovery tool as far as I can see, I discovered you can edit files too. Initially I wasted some time on the partition with /shares but when I realized I could edit files I went for /etc/fstab and commented out the line I mistaenly added. Swapped drives and did it again. Then I put the drives back in my MBL DUO and it boots file! :smiley:

I already have software problems with the MBL and have been moving files to another drive for a few days. I’m going to continue that until the MBL is empty, and then use one of the many methods discussed in this forum and other Internet sites, and reset the MBL back to factory condition. This will be somewhat facilitated because last week I emptied another identical MBL DUO (my newest one) in preparation for the the following:

I intend to format one of this MBL’s drives (after it is empty) or just remove the partition tables (should be equivalent of a new drive) and put it in the working MBL. If I’m not mistaken it should just rebuild the RAID array. Then I put it back in the original drive (and restore the other MBL’s second HDD) and format this MBL’s second drive and rebuild the RAID again. I’m pretty sure that will result in two factory default MBLs. Then all I have to do is configure IP addresses etc. and I should be good to go!

By the way, that MBL had most of my work since January 2015. I had moved about half of the files off already, but you can understand how distressed I was that it was bricked!

I learned an important lesson about RAID. It only protects against single HDD failures. If you screw up your OS then all bets are off. As a result of my lesson I’m going to start storing important data on TWO different NAS drives. Then I should be prepared for just about anything (except my house burning down).