I made a major discovery and big improvement about iso resolution today!


#1

Since I got the wdtv live I have thought that my dvd´s look so much better played on my dedicated dvd-player. Today, after like 6 months, I found out that I have to change the video output to 576p/50 hz. Now the wdtv play dvd iso like the dedicated player play discs. 

I have to change the output again when playing blurays, I use “auto”  - have used auto for everything since I bought the item - thought that was smart. It wasn´t.

Should´t the “auto” manage to play everything right? Todag, when I was trying to find the right way, i used my laptop with vlc and hdmi connected to the tv, and every file was perfect. No need to adjust on the laptop. Now my kids and my wife have to ask me to change the resolution on wdtv everytime they gonna see a movie. Any idea about the issue?


#2

Sounds like you are in a PAL country.  Auto should adjust to the best resolution of your TV.  576p50 is EDTV resolution PAL/SECAM.  Can’t you leave the WDTV at 576p?  Or do some videos look distorted?

One bit of advice from a person with a non-techno-savvy spouse to another, you might want to leave it at 576p50 and then ONLY CHANGE IT when YOU watch something.  Then switch it back.  That way the rest of the family doesn’t have to think about it.


#3

is the WD connected to tv through hdmi ???


#4

Thanks for your thoughts. But I have organized all of the movies in genre-folders and in alphabet-folders. It´s a nice system, the best way to organize a couple of thousand movies with wdtv. So than iso´s and bluray´s are in the same folders. I guess I jiust have to change resolution every day. I will try the Boxee Box or the Asus O´Play - to see if they can play the folder content automatically. And I am from a PAL-land, you´re right about that.


#5

Blu Ray´s look distorted on 576p, yes.


#6

Major discovery? This info has been around for ages. To reiterate: WD’s auto is not what one would expect it to be. It simply means that it chooses the highest  resolution your TV supports like 1080p60 which won’t do you much good if you playback material recorded on 23,976 FPS. Auto that adjusts to the material is done by bradds modded firmware.


#7

I tried b-rads modded firmware. Didn´t like it. The thumbnails came in 8 at a time - original come with 12. That means I have to scroll almost twice as much in folders having typically 200 movies. Thats almost 30 scrolls. Too much. A good modified firmware would at least let me choose12 thumbnails.

And it seems that bluray rips in mp4 play fine if they are 23,976 fps, 24 fps or 25 fps when in “auto”-mode.

Do you know if b-rad have made changes, so that 12 thumbnails can be choosen? And does it have enabled subtitle support in iso for ver 1.03.49? And does the adjustment to materiel resolution really work fine?


#8

No, I do not know. Why not ask him? And since subtitles in ISO have been working since like forever I don’t know why they shouldn’t do in his modded firmware.


#9

You know, enabled iso subtitles have been forever, as you say, but WD removed enabled subtitles in version 1.03.49. In 1.03, you have to manually make subs work, believe it or not. And that´s a pain for kids, wdtv is not all that intuitive that way…


#10

I’d rather not since in 1.04.17 they still play automatically both from ISOs and VOBs.


#11

R u shure? In 1.03. you have to enable every single iso from the option button? bluray/mp4 come automatically, but not iso. In 1.02. they came automatically. So again. R u shure?


#12

Absoutely, I’d just verified it before posting my answer.


#13

Strange. I have updated both of our wdtv´s to 1.03.49. Both have subtitles enabled. Neither start with subtitles, but I have to enable subs under “options”. Both played subtitles automatically enabled with 1.02… This is a bug in the udate.


#14

Or it’s a problem with your ISOs. To rule out it’s an issue with the update do a reset, then update the firmware and do a reset again. That way the player is in a defined state when updating and there should be no monkey business.


#15

tinuadmin wrote:

Strange. I have updated both of our wdtv´s to 1.03.49. Both have subtitles enabled. Neither start with subtitles, but I have to enable subs under “options”. Both played subtitles automatically enabled with 1.02… This is a bug in the udate.

I don’t see how that’s possible…  DVD support wasn’t added until version 1.03.   Or are you talking about ISOs WITHOUT DVD navigation?


#16

ISO support with navigation came in 1.03.49, yes. Before there were not possible to use dvd navigation, right. But. Subtitles was supported even with 1.02, and maybe earlier, I don´t know. As long as they were enebled, subtitles started right away.

They don´t do that anymore. They don´t start right away, even if they are enabled. They also have to be enabled under “options”, each and every single time. And that is a kind of annoying.

I even downloaded b-rads software today, but no change. B-rad have some other small changes that makes it a little bit easier, and is by that way the opposite to WD, who make small changes the wrong directions everytime an update appears.

As far as I see there are no competitors to WDTV, and WD can take the whole market for mediaplayers like Apple do for telephones. But they need to hurry with the updates, or else they can fall into the Nokia-trap: from best to worse in no time.


#17

My isos r perfect, no questions about that. And I did reset and update and reset again.


#18

My ISOs too and they have (and had) automatic subtitles. What can I say?


#19

Techflaws, can you disable your subs?


#20

Is it me then. Because I cannot tell any difference between letting the TV upconvert my 576p DVD’s rips to 1080i 60Hz or configuring the WDTV to 1080i 60Hz and letting the WDTV do the upconverting.

The only noticeable difference I can see is the poor quality of the GUI if I configure the WDTV to 576p. Should it be obvious or does anybody else see no difference in whatever does the upconverting. I am interested in case I am missing something and could improve my PQ - although I am happy with it the way it is - and don’t want to miss out.