I lost a large partition on my WD1002FAEX. It only has an empty 31.5mb partition

I tried several data and partition recovery programs and none see the lost partition. It was about 500GB I believe. What is the 31.5MB partition? What would have caused a partition to disappear so completely that it can’t be recovered? 

1 Like

I found out that the drive firmware reset the drive capacity to 31.5mb. Apparently this happens randonly on high capacity drives. I found a utility that restored the correct drive size (1TB) and am trying to recover the lost files. What a wierd bug!

weird what wetre you doing that cause this if anything ?

and have you heard of teh free program called TestDisk ?

its a console program but very powerful and popular because it work so well…

Nothing, apparently the drive initiates the change. I was able to recover the lost data using a program to correct the size and Easeus to recover the data from the damaged partition, but haven’t found a way to format the drive. XP disk management has an “X” on the disk # and lists it as unreadable. It asks me if I want to convert it to a basic disk and I don’t think I should do that. I can’t find a solution on WD knowledge base and can’t find a format download. Any suggestions? I want 2 500GB partitions on the drive.

Do you have any jumpers on the drive ?

You shouldn’t have any on there unless your going to format on XP.

here is the WD web page so you can verify what is correct if you use any jumpers ?


Are you sure your XP install is working properly ? fresh install ?

What about checking the event viewer under teh error or warning category for anything.

Disk man will do that if it detects a problem with the partitions so your partitions *may

not be repaired properly hence why your still having an issue.

Did you already save any data off the drive ?

If so if i were you i would use what is a typicaly called a low level format utility.

technicaly any tools that say that means they are writing zero’s to the drive. (they erase your drive)

there is nothing low level about it if you google search that term and see what its actually means lol

//sorry about the history lesson AND if you know this stuff i’m saying lol

i hate to assume what people do or don’t know on the net so i’m tryin to help you and anyone reading :wink:

Before i tried to do a low level format i would for sure use WD Diag for DOS or

another similar DOS based disk tool.

I hate to push the same stuff around here time after time but i use what works for me so…

If i were you i would download Hirens BootCD and have it installed onto a USB drive and that has

WD Diag and similar tools as well as low level format tools and it also has test disk and many partition programs. Its worth mentioning its free and does not contain any pirated products although it did many years ago (i lost count how many years i have been using it)

Its hard to stress how useful that BootCD is or similar and it can of course be burned to a CD/DVD.

anyway if you get that going you can bypass dealing with windows issues and i would also advise just unplugging your windows hard drive or any others while your work on the drive your having problems with that way you don’t accidently mess around with wrong drive.

here is the link to download the cd image you can burn or install onto a flash drive.


This is the link to a tutorial on how to put the cd image on a flash drive (using a small free safe tool)


so good luck and don’t underestimate how useful the event viewer is…

to anyone that doesn’t know where it is you can find in the control panel under admin tools

or right click the taskbar and select the checkbox in the start menu options to have the admin tools put into your start menu (no idea if this is ok for windows 8 though)

I have the same problem with WD10EAVS 1TB.

Could you give the name of this utility?

Thank You

The “31MB” problem is a FAQ. The same question turns up on a weekly basis in just about every storage forum.

There is a bug, but it’s not in the HDD firmware. Instead the bug is in the Xpress Recovery BIOS of certain Gigabyte motherboards and it affects 1TB+ HDDs from all manufacturers.

See http://www.users.on.net/~fzabkar/HDD/HDD_Capacity_FAQ.html