I just want to format MBL and use it as an ordinary external drive

I’ve lost my password, tried to reset…its all too complicated how do I just turn this into an ordinary external drive without passwords and a sharing etc. I just need the space

You perhaps got the wrong kind of drive. I think a MyBookLive is an Ethernet-attached drive that has to be accessed via some kind of networking protocol - various kinds of network protocols.

There are a number of Western Digital (and many other vendor) USB-attached external drives that don’t use network connections, but that doesn’t help you much if you already have the MBL. People on this forum can help you with the device you have, but probably can’t help you turn it into a different kind of device.

Yeah Well I can’t get it work the other way… got new computer ages ago forgot the password. I think it used to be connected to my Router, I gave up trying to get it work now I have the nbn…and I’ve plugged it into the back of my iMac Its been sitting in the cupboard now for a couple of years…I have no software for it I’ve tried to download some… but it wont install. when I plug it in if fires up and asks my for my password… I’ve reset it but nothing comes up to tell me for me to reset password…

The MBL is a Network Attached Storage (NAS) device. It can’t just be used “as an ordinary external drive”. You attach it to your local network - i.e., plug it into your router - and access it through your computer’s network connection. That requires some setup. And that setup requires your use of the MBL Dashboard which requires the admin password. The Reset process should have reset your password (to no password required).

What is asking you for the password? Have you accessed the MBL dashboard through your browser and the dashboard has userid and password fields you need to enter? (If so, just hit enter. The userid should be filled in for you, and the password is blank after a reset.) Or is your operating system prompting you for network credentials to access storage on MBL? Those are two very different scenarios. If the latter, ignore until after you defined MBL as you want it via the MBL dashboard.

Ok, I know you can’t define the MBL as you want because you seem to want a plain external drive. But that’s not what you have. So you have to go through the setup gyrations.

Ok, Thanks,

So I need to plug it into my router… How do I access the dashboard?
When I click on MBL which is sitting under shared. it says connect when I hit connect window pops up and asks for password or i could connect as a guest, but nothing happens and unit eventually turns itself off.

Thanks for trying to help though I really appreciate it. I’m going to try and set it up again and plug it into my Router. It used to work brilliantly then I upgraded my computer. I’ve heard people mention Twonky… I used to have that. Do I need that for this device?

Update i have connected the MBL to my router and it has appeared again on my computer under shared and once again i cannot connect as it is asking for password. Is there a Manual on line somewhere I see if I can find it

Ok Some success I now have Dashboard!! Hmm Not sure what to do now

Have looked for update on firmware and I now get this message
31102 - Device does not have enough space for upgrade.

What you do next sort of depends on how you want to use the device. Assuming you want to use the device as external storage for a computer you will have to define one or more “shares” that you will access as external drives.

On the Dashboard select Shares. It will show any that you already have defined. There will be one named “Public” than will not require network credentials (i.e., name and password) to access. And you can define other shares that only specific users can access.

After you define private shares, you will have to go to the Users tab to define the users and their passwords, and tell MBL which shares they can access. These userids have nothing to do with the userids on your computer(s). They are just names and passwords needed to access the data on your MBL.

Also, in the Shares display you will see if you already have shares defined and the amount of data in them. You will have to decide whether or not to keep them.

After you have that set up you need to tell your computer how to access these shares. I fumbled around on Windows and got that to work, but I have no idea how to do it on a Mac.

This might mean that you already have shares defined and the device is full. Deleting some of the data from some shares may get you past this problem.

I can’t see any files at all to delete. And I didn’t have any shares set up. How do I just reset it to factory defaults I don’t care anymore if I lose all the files.

I think you better check the documentation or do some web searches (unless someone else answers here) to get that information. The normal Reset - shoving a paperclip into the Reset hole (located on the back of the device) for 4 seconds - supposedly resets the password but leaves allocated storage untouched. I vaguely remember some more complicated technique involving holding the reset button for much longer and maybe turning the device off and on while holding the reset. (But that may have been for a different device.)

Do you know that you need to do a full reset? Have you tried allocating a share with the device as it is?

As I recall, you got the :not enough space" indication when you tried upgrading firmware. Do you know you need new firmware? Even if you do, downloading the new firmware to your computer and then updating “from disk” might get around the problem.

It told me I had to update the firmware… I have created a share… but I still can’t see anything. I’ll try downloading to my computer and then installing from file… after that if nothing works I’ll reset the whole thing…

How is it going?
Are you still on it or have you given up to use a “normal” USB-drive? :wink:

After the full reset, you should have a MBL with factory settings. When you go into dashboard then (no password should be needed) there should be some status information of the device on the bottom of the dashboard … total storage/available storage/ … does this show a valid information? (~ 2.7TB for a 3TB MBL)

if YES: try to generate shares or use the predefined /Public share (try accessing it via your imac with no credentials)
if NO: something might be wrong with your drive partitions go to settings -> tools -> restore factory settings (will take a while, after that reboot and try again)

if still not working: you might have to SSH into the drive und use some Linux magic to get it up 'n running.

I’ve 5 Books Up 'n running connected to a GB-switch.
1 x stock 3TB MBL (WD-Firmware)
2 x self build 6TB MBLD (WD-Firmware)
2 x self build 300GB MBL (4.1.5 Kernel, Debian Jessie)
every book has samba running and I do have access of all shares on my whole network.