I just lost 2 partitions of My Passport in OS X 10.9

I have a 1Tb WD My Passport with USB 3.0 and it has always work alright in Mac, but today when I connect it, it only appears one of the 3 partitions I had.

I run the disk utility and I can see the other 2 partitions. One of them is unmounted and without information, but still with the name I put, the other one has a different name.

I understand there is a problem between some external hard drives and OS X 10.9. I didn’t have any WD app installed, I have never use it. The computer I was using was a new Macbook pro retina with 10.9 from factory.

Any solutions for recovering the lost partitions?

Hi pablotraveler, did you tried clicking on the Disk Utility repair option? Check the link below for the steps. 

How to test a drive for defects or problems on a Mac


 Disk Utility repair option doesn’t repair anything. Thanks, I will check it out.

In the meantime…

By the way, may be it is silly, but I wrote this in Apple forums and another person had the same response.

Something curious:


I had disable spotlight in one of my 3 partitions. That’s the one that is still working, the other 2 are the ones that unmount in my WD My Passport 1Tb hard drive.


May be spotlight is part of the problem?

Another person reply:



I had two drives connected to my iMac i5.

1.)  FreeAgent Desk Seagate Drive 1TB  was connected through FireWire. ( the affected drive )

2.)  WD MyBook Drive 3TB  was connected through USB. ( not affected )


INTERESTING part is… The WD Drive was already added to the Spotlight Privacy to " Prevented Spotlight from searching these locations"  BEFORE i installed Mavericks.


The affected Drive had certain folders in the Privacy and those specific Folders were NOT affetcted but all other files on that Drive were.  hmmmm… And all the files affected were between 11:50am and 2:00pm. I will see if i can find out if there is a log file of when Spotlight Indexes.  I know I’ve caught Sportlight Indexing more than it should latelly too.


So MAYBE this IS a Spotlight issue?? 


I know there are people in this forum that the problem keeps happening repeatedly, maybe they can TEST out this theory and add that drive to the “Spotlight Privacy” and see if that eliminates the problem.

I have solved my problem, and I have recover my lost partitions, and all my data!

My solution here, try and let me know if it get fix for you too.

Add “/Volumes” into spotlight privacy (since ext HDs are mounted under this folder).

So open up terminal and enter: “open /Volumes”

The above command will open a finder window containing /Volumes. Drag and drop that folder into Spotlight.

After that connect again your hard drives with lost data and lost partitions.

They will probably still don’t mount, but you can go to the disk utility. You will see the partitions back but unmounted. Repair the hard drive, repair de partitions, try to mount them again… I had to try to repair two times and try to mount another couple of times… But finally I got my 2 lost partitons back!

My hard drive is a WD My Passport 1Tb with 3 partitions. Good luck!