I have no "Public" folder


#4

Okay… a bit odd but not an actual problem afaik. I guess you can just create a public share if you want to. If it complains use a different name.


#5

Thanks. The problem, as I see it, is that it prevents me from mapping a single network drive that would contain all of my shares (music, videos, audiobooks, etc.). If there were a public folder, and if all my shares were inside that folder, I could map the public folder as a network drive. As it is, it looks like my only option, if I want to map a network drive, is to map my “music” share as its own drive, the “videos” share as its own drive, etc. Maybe I’m missing something, but I cannot see any way in Windows to map the entire NAS volume as a network drive; and since there’s no single “public” folder that contains all of my shares, there’s no single folder I can map as a network drive that will contain all of my content.

The best semi-workaround I have found is to create a share that I’m calling something like “MapToNetwork.” Inside this share, I place links to my Music, Video, Audiobooks, etc. other shares. I then map the “MapToNetwork” as a network drive. When I click that network drive, I see the subfolders for all my content types (really links to each subfolder)


#6

The way the “Public” share works by default wouldn’t have helped in this situation, as it sits alongside the other folders as another Share (the only thing “special” about this folder as it [should] come out of the box is that you cannot set it to private in the web UI).

Your workaround is a solid one; and if you don’t add/remove shares often, then it shouldn’t be an issue (you could also do this with symlinks from inside of the NAS itself but in the end, it’s the same result). Windows has always been like this, requiring a \device\share in order to see it as valid. There is, however, a way around this. It involves editing the samba.conf inside of the NAS and creating a new entry that links to the /shares folder. You could give it a name like “origins” or whatever you want really and then you’d be set. If there is a desire for a how-to/guide to accomplish this, feel free to reply to the thread.


#7

Thanks very much for the info, tonyrayo. I didn’t realize that the public folder sits alongside the other shares. In that case, I’m really not missing anything I need by not having a public folder.

I am interested in the details of how to edit the samba.conf to create a new entry that links to the /shares folder. I appreciate you sharing the instructions, when you have time. Thanks.


#8

Hey @adam8281, just FYI, I haven’t forgotten about this topic. It was pretty easy to make the addition/edit (/etc/samba/smb.conf is actually well laid out) however it kept getting overwritten (and continues to do so) which I might expect on reboot but no, it does this on other edits as well as seemingly at random like it has a will of its own; a will I must break :stuck_out_tongue:. I’m going to reach out to someone that knows more about this funky little box. To be updated!


#9

You the man!


#10

You were mot looking in the right place. In left pane of File Explorer, you need to see the Network section, and open it, there you will see your NAS, open it, and all folders, incl Public. and the three shared folders for music, pictures and videos are there in Public.


#11

Thanks for the response @mike27oct. But it is not there in the Network view.network%20view


#12

It’s there – in the MYCLOUDPR2100 – your NAS. Click on the NAS you see listed to open up the view, and Public should be in there along with the other folders I mentioned.

Do you have a copy of the complete user manual from WD? You should look at it!


#13

When I open up the view, this is what I see. No “Public”network%20view%202


#14

Yes, it does appear you have a problem. I am including a screen shot of what I see on my system, and what I believe you should see on yours.

Picture shows My Cloud open in Network section, (left pane)
Public is highlighted and open and viewable in right pane. Hope this helps.

I suggest you contact WD Support via phone for further assist.


#15

Your system is a DL2100, op has PR2100, while they are quite similar they seem to display network shares differently (annoyingly) x.x


#16

They are more alike than different. Don’t confuse the issue with this. My DL2100 was model before his. He may be looking at a different format of File Explorer.

BTW, which model WD NAS do you have?


#17

No need for any hostilities, just trying to help another user find a solution (even the EX line seems to show network files like you’ve shown). I have a PR4100 for what it’s worth :slight_smile:

Edit: The only change I was able to make related to the Public folder was by enabling DLNA Media Server (Media Streaming), this created “Shared Music”, “Shared Pictures” and “Shared Videos” but that’s what I would expect to see (these are just empty folders that you would start to use if you wanted to publically stream media files to other network devices using DLNA).


#18

Yes, I have those media folders filled with media files. I think they came ready at the get-go. Not so sure turning on DLNA streaming created them. I don’t even use DLNA to stream. I prefer using Network shares; the NAS does both. The MC app uses samba shares, not DLNA. I find DLNA “hokey” compared to nework/samba shares. iOS devices (and apps) use samba, not DLNA.

So, does my screen shot of the NAS look much like yours on your NAS? I bet it does.


#19

Yeah DLNA has never been solid (as far as communication between media devices, I like Miracast). Sony and company have managed to shove DLNA into a lot of products (even my FiOS STB shows up as a DLNA device, with channels as folders!) My setup is SMB-based (as are the shares used by My Cloud as you mentioned) alongside NFS. I was just trying anything and everything I could think of that might cause a change, but I still think the editing of the Samba config itself is going to be the only way to get a network drive to mount the root of the shares directory.

My Windows setup looks a bit closer to @adam8281’s (I’m not sure if this is due to running Windows 10 or not); I only have my laptop (DESKTOP-UIK34O5) and PR4100 (HOME-PR4100) turned on at the moment in terms of what Windows labels “Computers” under the Network (other network attached devices such as printers, Android devices, routers, etc are in other categories and do not show up here by default).


#20

iIteresting. Both my Win 7 and Win 10 screen shots of FE look the same.and not like yours or OP’s. I do not have separate music and video folders along side of Public. They are all within the Public folder as my picture shows.It’s likely because I actually use the Public folder’s media folders.


#21

It’s Windows 10 for me, too.


#22

@adam8281, just make a Multimedia share in the shares tab of the web UI and enable Public and media serving. It’s exactly the same as a ‘Public’ share, just with a different name.
Map the share in windows, add a Music / Video / Whatever directory.

Shares are only useful when you need advanced permissions: limit access to Pictures for yourself only, share Movies as read-only with your family, disable media serving on your business related pictures …

If you want to move the data quickly between shares, don’t use the mapped folders in windows, but use SSH (e.g. with winscp). Example moving content from /shares/Music to /shares/Multimedia/Music.
This is because moving data between mapped shares with windows will move all data through your windows machine (which is slow) while it is instant with winscp (the data doesn’t have to leave your NAS).
Note that I said moving the data (cut-paste), not copying the data… but even that goes a lot faster over SSH for the same reason.


#23

Thanks @Tfl that’s a great suggestion