I Have Big Trouble With My Passport Essential 1 TB

Well,  my drive has a password proctect, of course i put the key in drive.

On last night, the windows 7 ultimate told me that you must check and correct your usb disk drive so i checked and then s-hit. My drive lost, windows 7 didn’t see the my drive. It has 500 gb data, and nearly all my life ( photos,videos, my studies, my programs ( i am programmer) ) was in there.

And then i tried to solve this situation with very kind of ways, i remembered that one of those ways told me “the drive is raw” so i run ubuntu 12.10 from another usb stick. But i couldn’t run “unlock.exe” because it is window’s program so i installed the wine (run windows programs on linux) and then i try again to run unlock.exe but again s-hit. Because unlock.exe has dependent to .net framework 4.0 . So ı try to install .net framework 4.0 on linux but i couldn’t install…

Now, my real problem is data.

How to get back them?

Is there anybody to give me solutions about this?

Can MacOs System fix this situation?

or how to run unlock.exe on linux?

or how to uninstalled the password protect?

Thx for replies…

I have a same problem… Windows 7 didn’t detect my drive… How can I solve this?
Really waiting for replies…

i will suddenly wait  answer!!!

nor format nor factory settings!!!

what is this, very bad strategy , how i can format or sign into disk 

i need this disk…