I Guess I Still Don't Understand Playlists

I thought from reading posts on this forum that I understood relative playlists, but I can’t get it to work and only getting the “There is no media in the current folder” error message.  I can play the .FLAC files, just not with this playlist.  I have rebuilt the Media Library but it didn’t make any difference.  I am running 2.08.13 firmware.

Playlist is located in this directory on the WDTVHUB and the directories containing the music files are also located there:

  [\WDTVLIVEHUB1\WDTVLiveHub\MUSIC\WDH1_MM_Sync_Music](file://%5C%5CWDTVLIVEHUB1%5CWDTVLiveHub%5CMUSIC%5CWDH1_MM_Sync_Music)

the last few lines from a DIR command in this directory are:

10/20/2011  21:35             RTR-Tape-OPS34A
10/20/2011  21:37             RTR-Tape-OPS35A
10/20/2011  21:38             RTR-Tape-OPS36A
10/20/2011  21:39             RTR-Tape-OPS37A
10/26/2011  10:55           1,826  PL-All-OPS_REL0.m3u

A few lines from the playlist that doesn’t work are as follows:

RTR-Tape-OPS_NAB10_03B(Everything I Do) I Do It For You{Adams, Bryan{1991{RTR-Tape-OPS_NAB10_03B{29{
RTR-Tape-OPS10A(Girls, Girls, Girls) Made To Love{Hodges, Eddie{1962{RTR-Tape-OPS10A{10{Various{.FLA
RTR-Tape-OPS17A(He’s My) Dreamboat{Francis, Connie{1961{RTR-Tape-OPS17A{28{Various{.FLAC
RTR-Tape-OPS21A(He’s) The Great Imposter{Fleetwoods{1961{RTR-Tape-OPS21A{39{Various{.FLAC
RTR-Tape-OPS22A(I Can’t Get No) Satisfaction{Rolling Stones{1965{RTR-Tape-OPS22A{38{Various{.FLAC
RTR-Tape-OPS08A(I Do The) Shimmy Shimmy{Freeman, Bobby{1960{RTR-Tape-OPS08A{10{Various{.FLAC
RTR-Tape-OPS_NAB10_01B(I Just) Died In Your Arms{Cutting Crew{1987{RTR-Tape-OPS_NAB10_01B{27{Various
RTR-Tape-OPS03A(I Wanna) Love My Life Away{Pitney, Gene{1961{RTR-Tape-OPS03A{01{Various{.FLAC

Can anyone indicate what I’m doing wrong?

Thanks

Are the file names really that long???

Not sure if it makes a difference, but try substituting “/” instead of “” in the paths.

All of my playlists are “forward” slashes.

Thanks for the reply TonyPh12345.

Yes the filenames are that long and some are longer than the excerpt I listed.

I changed the backward slashes to forward slashes and rebuilt the Media Library but got the same result.

I should have also explicitly stated earlier that I was trying to run the playlist from the WDTV Hub internal drive.

Interestingly, If I chose my Synology DS410 NAS as a Network Share in the WDTV HUB the SAME playlist on the DS410 works fine.

Since you were kind enough to reply I hate to put an editorial comment here, but I can’t resist.  If I had it to do over again I would have spent an extra $200.00 to buy a laptop on sale instead of the WDTV Hub for the following reasons:

  1. Poor incomplete documentation almost devoid of any technical information such as what tags are read from what file types.

  2. Very slow response time from WD for fixing bugs and shoddy testing of new versions before being released.  Browsing this forum pretty much proves that.

  3. Wasting time adding “useless” services before fixing the basic functionality of the device.

  4. No choice of using software other than WD’s.  Of course thats true with other similar devices.  On a PC there is a multitude of multimedia players to chose from.

So essentially my WDTV Hub is pretty much useless for playing music in a stand-alone environment, but at least I know I don’t need to spend anymore time with the playlist problem since it appears to be a bug.

Thanks again for the reply.

Try the reverse.

Try playing the playlist in a PC client (iTunes or whatever) from the HUB’s drive.

Hi again.

I tried what you suggested using MediaMonkey and VLC media player on a W7 64-bit Home Premium notebook.  I don’t have any iPOD type of device to test with.

Navigating to the WDTV Hub network location, neither MM or VLC would play files using the playlist.  They would play the files if they were specifically selected.  Both MM and VLC (and the Hub) would play the playlist located on the DS410 NAS.  The playlist was originally created on the Hub by copying the playlist file from the NAS to the HUB.  Interestingly, MM would show the playlist media files but would not play them.

I then started to experiment.  I created a new test directory in the existing directory tree named ATESTDIR.  Then I copied one of the existing .FLAC files to the test directory and renamed it to a short name with only alphabetic characters.  Then I edited the playlist to only include that file.  After doing that the playlist would play the file from MM, VLC, AND the Hub.

Then I thought maybe the Left Braces character { was causing the problem.  I renamed the test file to put the two characters {2 at the end of the filename before the period and updated the playlist to match the new filename.  Again, from the playlist MM, VLC, and the Hub played the files using the playlist.  So it seems as though the Left Braces character (at least one of them) isn’t causing the problem.

So as of now I still don’t know what is causing the original problem.  As time permits (since there are a lot of possible combinations to test) I may do more experimenting to see what condition causes the problem to reappear.  If I determine that, I’ll report back.

First I just have to ask.  Why are your file names so long?  Having file names that long is really unnecessary.

The first thing that I would do is to shorten you music file names, preferable using standard music naming so your albums would look like this:

01 songname.flac

02 songname.flac

03 songname.flac

etc.

Any extra info for each song (album title, year, artist, etc) can be added to the song tags, rather than having them in the file name.

Then, if you haven’t already downloaded it, download Playlist Creator, and install it on your PC. 

On the root of the HUB create a folder and name it something like “Playlists”.

Then open Playlist Creator, then click on “Settings”.  A new window will popup, on the left side click on “Playlist Details”, then were it says:

Do you want to save the playlist entries absolute or relative?

Click on the dropdown box and select:

Relative (e.g. “…\MyMusic\MySong.mp3”)

Click “Apply” then “OK”, then create your playlist.

Your playlist need to be saved to the new “Playlists” folder that you created on the HUB.

Sample Playlists:

M3U PLAYLIST

#EXTM3U
#EXTINF:188,Eliza Doolittle - 11 - Pack Up
…\Music\Eliza Doolittle\Eliza Doolittle\Pack Up.flac
#EXTINF:232,Club Can’t Handle Me -  - Club Can’t Handle Me
…\Music\Flo Rida\Club Can’t Handle Me.mp3
#EXTINF:176,St. Elsewhere - 2 - Crazy
…\Music\Gnarls Barkley\Crazy.mp3
#EXTINF:276,31 Minutes to Takeoff - 15 - Cooler Than Me (Gigamesh Remix)
…\Music\Mike Posner\Cooler Than Me (Gigamesh Remix).mp3
#EXTINF:189,Everybody Wants To Be On TV - 1 - This Ain’t A Love Song
…\Music\Scouting for Girls\This Ain’t A Love Song.mp3
#EXTINF:233,Teenage Dream - 3 - California Gurls
…\Music\Katy Perry\California Gurls.mp3

PLS PLAYLIST

[playlist]
File2=…\Music\Eliza Doolittle\Eliza Doolittle\Pack Up.flac
Title2=Eliza Doolittle - 11 - Pack Up
Length2=188
File3=…\Music\Flo Rida\Club Can’t Handle Me.mp3
Title3=Club Can’t Handle Me -  - Club Can’t Handle Me
Length3=232
File4=…\Music\Gnarls Barkley\Crazy.mp3
Title4=St. Elsewhere - 2 - Crazy
Length4=176
File5=…\Music\Mike Posner\Cooler Than Me (Gigamesh Remix).mp3
Title5=31 Minutes to Takeoff - 15 - Cooler Than Me (Gigamesh Remix)
Length5=276
File6=…\Music\Scouting for Girls\This Ain’t A Love Song.mp3
Title6=Everybody Wants To Be On TV - 1 - This Ain’t A Love Song
Length6=189
File7=…\Music\Katy Perry\California Gurls.mp3
Title7=Teenage Dream - 3 - California Gurls
Length7=233
NumberOfEntries=7
Version=2

I’m pretty sure that there’s no issue with the PATH length, but there might just be an issue with the filename length.

Linux / Unix allow a 255-character limit filename, but the WD’s application may have further limits, although it would seem odd that the limitation would only appear if the file were saved LOCALLY as opposed to opening the exact same file from the NAS…  

But the fact that the PC won’t play it when accessing the Hub makes it seem like there MAY be some discrepency in the path names as they appear on the HUB versus how they appear to the OS when accessing them via SAMBA.

You do, indeed have a mystery on your hands!  :)

I also don’t know off hand what the behavior is of the Hub would be if a single item in the PL is invalid…  Does it invalidate the whole playlist or just that entry?   I don’t know.  Never tried that.

I hope you all are not forgetting that the firmware release before this last one will not work at all with playlists. I use playlist creator and have no problem creating them it is simple click and go. I have the playlist stored on the root drive of my nas the only problem I do have is when writting it to my nas it takes forever to create unless I unplug all my hardrives that are plugged into it then it creates it in about 30 seconds

TonyPh12345 wrote:

I also don’t know off hand what the behavior is of the Hub would be if a single item in the PL is invalid…  Does it invalidate the whole playlist or just that entry?   I don’t know.  Never tried that.

 

I haven’t done this in quite a while, but I do know that in previous firmwares if I deleted or moved a file but forgot to update the playlist, the HUB would skip that file and move on to the next.  But this was a few version back, so I don’t know if it will still do this or not.

Also, speaking of file length, another issue is trying to add metadata for the file.  If you come across something that you can’t use “Get Info” for to add the metadata and have to manually add, the longer the file name the harder it is to get the HUB to recognize the .xml file.

You have all been great at helping me with this problem!

After fooling around with this all morning I think I found the problem, but not what caused it.  I made a new playlist with about 100 entries and commented the lines out by putting a # character in column 1.  Then I started to uncomment the lines a few at a time to see if I could find a pattern to the failure, which I couldn’t.

Then I started to do DIR commands on some of the failing items and I found that some characters in the filenames were incorrect and didn’t match the Playlist (correct) names.  This must have been the problem from the start and the only way I can think this happened was:

  1. Some kind of error during copying the files to The WDTV Hub.

  2. A MediaMonkey “Sync” error that didn’t sync the files with the correct filename sometimes.

So what I’m doing:

  1. I deleted all the audio files from the WDTV Hub.

  2. Currently am re-syncing the files with MediaMonkey.

  3. If there is still a problem, that seems to indicate a MediaMonkey bug.

If the re-sync fails then I’ll:

  1. Redelete all the audio files from the WDTV Hub once again.

  2. Use the COPY command from my TakeCommand command processor to copy the files.

This will take hours to complete the sync, but I will report back with the result.

Thanks again for your support.

Well I said I’d report back, and the problem is basically fixed.  In my previous post I indicated possible things that might cause this problem but I left off the most important one.  As much as I hate to admit it, this was A USER ERROR.

The mistake I made was in the MediaMonkey output format “masks” used to sync the files.  When I had done the original sync I used masks that generated the filename from the different items in the MM database, such as /{{{{{{

This was fine until I made my first correction to the database values.  Now the playlist filenames did not match the filenames for the few corrections I had made.

What I should have used, and did use once I figured out the problem was a mask /

  This way the synced filenames would match any corrected names.  After using this on the resync of a cleaned out WDTV Hub music directory the playlist worked.

I verified this problem by doing a DIR command to the Hub and redirecting the output to a .txt file.  Then I did a file compare of the .txt file and the .m3u file and saw there were differences and recognized some of the filenames as those that I had corrected.

One thing I’m going to do in the next couple of days is to write a batch program for my J.P. Software TakeCommand command processor that will find all .m3u files on the Hub (or other specified storage location) read the .m3u files and make sure that the files referenced therein actually exist, and display messages of any errors found.

I actually think the Hub does this test for a playlist that is selected, it just doesn’t put out a very informative message.  I tried making just one error and got the “no content” message.

For those who wondered about my filenames.  These files came from reel-to-reel tapes I had recorded years ago, whence the RTR in the Album/Directory name.  The ones with NAB10 were from tapes on 10.5 inch NAB reels and the others were from 7 inch reels.  I digitized the tapes with Magix Music Studio 12 a couple of years ago, and while the tapes were playing I was usually reading an SQL Server or C programming book.  Each time there was a break between songs I would set a MS12 Marker to show the approximate separation point.  So after that I ended up with albums with one big “song”.

That project sat for a year or so and I finally deceided to split the tape into the individual songs.  I used MS12 to find the previously set markers, fine tune the separation points, split the items into “Objects” and normalize each object.  then came the issue of naming the Objects.  My version of MS12 only outputs to .WAV files and the editor in MS12 is not very user friendly and didn’t store all the tags I wanted,  BTW, I don’t think the WDTV Hub reads .WAV RIFF tags.  In any event I deceided to use the Object Manager to name the Objects that would become the exported filenames.  The left braces { character was a field separator character.  I had a book I used to verify the actual song titles, artist names, and date.  Then I imported these files into MediaMokey converting them to .FLAC files and setting the metadata tags from information parsed from the filenames.  I guess I could sync the files to the Hub in any filename format I wanted, but since I spent so much effort on this I’ll leave them as they are.  Also as the filenames scroll across the screen I can see the Date (year) which I haven’t seen displayed so far by the Hub anywhere else.  If you sort by date the Hub seems to use the file date not the date stored in the metadata tags or maybe the Hub requires a full date not just the year.  I could write another batch program that executes METAFLAC.EXE to extract the date and use TOUCH to change the file dates.  However I’ll leave that for another time.

I’d like to thank again the people who worked with me on this problem.  Sorry to have wasted their time on my user error.  Finally, I’ll bet nobody ever asks me again about my filename naming convention.

Hi - glad you found your problem. Just one more thing to watch out for: the hub is very particular about filenames. It is case sensative (Alpha and alpha are considered different files) and sensitive to trailing spaces (you can’t have any). Windows doesn’t care and will parse the filenames to find a match. This is why a playlist may work fine when run from a computer on the network but won’t work on the hub.