I got mybook running with timemachine. good

Ok, bought a 2TB mybook live some months ago. Tried it with my mac (osx 10.9.4) and it was too slow for reality. Latest firmware and all but still slow. Well, not slow, more like nothing happening.

Today I did one last attempt.

  1. Latest firmware on mybook (which in my case already was installed)

  2. Factory reset (long, ran for at least an hour or so)

  3. Add password to admin user

  4. Remove public access from default Timemachine share

  5. Allow admin user to default timemachine share.

On my (obsolete) home wifi timemachine is now running an initial backup. Speed is ok (old linksys wgr54 router), 4GB at around 30 minutes. Good enough for me! Yes. good. Try it!

Ok, although speed was higher than ever before it simply doesn’t do it for me. No more attempts at ever using this drive with OSX again.


To improve transfer speed, make sure that you are using the drive on a Gigabit  environment. Also make sure that the firewall of the router is not blocking the connection.

Also you may want to check the remote access tab of the user interface to determine whether you have successfully created a remote connection, or whether you have a relay connection. If you have a relay connection, that could be why connecting to the device is slow or freezes. You may have to enable port forwarding on your router, which will create a direct remote connection with your My Book Live. You may find assistance in enabling port forward on your router at the following link.

How to enable port forwarding on a network router for use with a WD My Cloud, My Book Live, or My Book Live Duo ”: