I give up. No more updates from WD. Someone knowns a good MKV player?

After one year waiting for a new firrmware for WD Elements Plat 2 TB, I give up.

Several post, severals emails to WD, and my conclusion.

WD appears to stop working on this device and focus in new products.

No date for new firmware, no compromise of fix important BUGs.

Not event bugs. The problem is the product is NO-ENDED. I can understand nowadays. 

By the time the product arrives the store and people buy, the new version is ready… or almost ready.

But MKV aspect ratio not soported, and several problems that make impossible to read some subtitles make me imposible to play my mkv collection.

And I am waiting for ONE YEAR, and yesterday  I was told by WD, that no new version is comming.

Then I have a cute(but slow) external HD for my computer…

And I need a good PLAYER for MKV with HDMI output…

Somebody own a (real) MKV PLAYER. I wish to be advise about good players. (price is not important)…

thanks.

acryan

It’s problem is that it has 1 graphics (and audio) chip, so problems occur when u are playing a video and decoding audio. There are less problems when u use digital output, because then it is passthrough.

I just use this for DVD ISO as I have a large collection of series, which are difficult to watch due to hasstle factor. 1TB worth.

The new update for Asus HD2 is quite good, for now I can play 5.1AAC.

P.S

[Deleted]

I can understand your frustration.  I too have a large (~1.8TB) collection of MKVs.  I know the aspect ratio is a problem and 16:9 doesn’t work, but if you choose 4:3 it works just fine (on my TV). It seems to work the wrong way round.  Have you tried it on 4:3?

I can’t help on the subtitle problem.

Hi  johnaduk.

The trick you said could work to watch some films.

But another films that are ok and are plays fine will be deformed.

This settings sould be match your TV format.

It´s very annoyed in the minute 1 o 2 of the film stop and chage the setting and play again praying for best results…

For me is hard to accept:

  1. the chipset appear to be inefficient to implement MKV. Perhaps future chipsepts more powerfull could be enough.

  2. The firmware is buggy and unable to use the hardware potential.

  3. WD abandon us… WD abandon formware updates.

If no more support is giving and I have to buy another product that really works, Then I look for another trade.

bye.

For me it’ll be the last product  I’ll buy from WD, and will talk trash about this company all over the web.

I have just got my brand spanking new Elements Play 2TB.

Interestingly, I go into settings, it says my current firmware is 1.01.12. This is what the website says about this firmware. ‘New Release - Firmware Version 1.02.12 for the My Book World I & II (10/19/11) ‘ The website says the latest is 1.01.10. Does my box have more up to date software than the website does? Or have I got the wrong HDD in the box?

I have tried to update the firmware to this one and it will not pick it up from my USB

On top of which, after 30 minutes of it being plugged in, here is a list of problems so far:

Cannot copy multiple files. Pressing the search button does not bring up the ‘list of operations. It brings up the 2 search options. These are ‘Begins with’ and ‘Contains’. There is no keyboard as stated in your user manual.

I can copy a SINGLE media file but that fails. It copied the first 3 seconds. This was done by finding the single media file, NOT the folder, pressing the right cursor and pressing options. It gave me 2 options. COPY or DELETE. NOT the list of options as stated in your user manual .After trying to copy for 10 minutes, the box rebooted for no reason whatsoever. After rebooting, it ejected my external hard drive. I had to pull the power out of both the box and the external hard disk to get it to pick it up.

I tried to delete the 3 seconds of media and managed to do this but it WILL NOT delete the folder

The box has rebooted itself quite a few times now and it has now said cannot find internal hard disc. It does eventually find it but this is worrying.

My external hard drive will not power down.

Is this what I can expect from WD as the last product i bought went a bit wrong as well. I tried to call for support, and got “we are busy at the moment, so please leave a message and we will call you back” shortly followed by, “this message box is full”

Bit ■■■■ so far. Not a happy bunny

Hello,

You can try contact WD by email. 

To Contact WD for Technical Support
http://support.wdc.com/contact/index.asp?lang=en