I get an error saying maxium upload size is 5GB

"I want to load a video to MyCloud that is 10.3GB.
I get an error saying maxium upload size is 5GB.

Can this be modified/lifted/increased? Thanks,"
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

This is the email I got this evening by somebody trying to upload to our my cloud shared drive what else is there to say?

I’ve been trying to find a way around this newly acquired “feature” of a 5GB limitation.
I tried uploading over SFTP on Saturday the content from that day which was 93GB and the combination of a super slow frontier Internet connection at the person’s house and the entire unit locked up the SFTP remote access. And remote web access is not working either so I can’t reboot it remotely.

edit: I ended up going over there on Sunday evening to finish that upload of 190GB of the two days that way I wouldn’t have to worry about it and I forgot to hit restart while I was there. edit end.

I could enable FTP but FTP is not secure and has had numerous directorie traversal issues.

This limitation cannot be modified or changed on the My Cloud device side by the end user.
FTPS or SCP via SSH can be used for larger files.

FTPS or SCP I don’t remember seeing either of those settings in the GUI. and I need individual user accounts SSH seems to only use the “back up key”?
one of the other members contacted support and they told them to use FTP, LOL because that has no directories traversal issues…/…/…/…/…/…

I’m also under the impression that anything in the command line does not get saved.

and on SSH i get “Connection refused” so a restart Will be required I guess when I go over there.

The following KBA will help

“The limitation cannot be modified or changed”
My sweet hairy petunia.

Of course it can be changed. . . .it would be a simple matter to adjust this, but it must be done on the WD servers. For some odd reason. . . .WD does not want to support medium sized file transfers (5GB is not “large” by any stretch of the imagination in 2021). I can guess the reasons. . . .but I know nothing for sure.


However, given that WD does not want to grant 5GB transfers using there servers, then one must look for other answers.

I am not sure FTP is the best answer. . . .

I would seriously look to establishing a VPN setup.
Once you establish a VPN connection into your network, you can access the NAS directly as if it is on your own network using finder/explorer

Another alternative is to use SSH and then a program like WinSCP to execute the transfer.
Although, to be honest, you probably want to do that with a VPN connection anyway. . . .

1 Like

Thanks.
I’m assuming the limitation wasn’t there prior to the announcement in the change log for OS5.
I also realize there could be NAT traversal issues with FTP.

I Tried using cyberduck with SSH/SFTP I thought I had it working with the user password and not the “Remote Backup Server” password. When I poked at it again I wasn’t able to get in unless I changed it.

Had this person not already a WD product the MyCloudEX2Ultra I would’ve went drbro or synology ( at Home I’m way happier with it, it Doesn’t feel like a fisherprice toy ). I Think VPN is in our future.
Instead of the EX4100 & PR2100 (the last one has been giving me headaches I’ve gone through 3 drives, I don’t know if it’s because we got it used or if the drives were bad or shipping was unfriendly).

the user experience alone in the GUI is enough not to recommend, lacking common settings.

Okay I did take a look at the article I wasn’t going to.
and I see FTP over TLS/SSL is supported that would’ve been helpful to know.
Sadly FTP is not really user-friendly? And can have NAT traversal issues seeing how it uses two ports for bidirectional.

FTP TLS SSL + NAT :_( cant “Report external IP in PASV mode” as DNS name:port only IP. and NAT NEEDs 55536-55663 maped 1 by 1! By one router That would be 127 Port forwards!

this is why i use SSH/SFTP at home, only port 22.

Ok I set 55536-55663 to xxx4-xxx5 + xxx0(21) TCP mapped 3D-NAT {RouterNAT>DviceNAT>MyCloud}. and in NAT CDuck can connect to DNS.DN.com:xxx0!, I need to test on CellCon.

but what if “Report external IP in PASV mode” IP not the same as WAN??? will that brick it? hmmmm.

FTP was not meant for use on NAT! need to work on VPN…

Everything was working great, tested on a cellular connection. went home thankfully only 20 minutes away and five hours later went to test it … guess what IP address change and nothings working. I have dynamic DNS set up but FTP doesn’t like a non-static public IP. I was hoping we wouldn’t have to buy a raspberry pi and spend the time configuring it, powering it yet.