I figured it out!


#1

“unable to play the selected file please refer to list of supported formats” and “there is no media in the selected folder”

are both caused by the file/folder properties/permission being set to “none” instead of “read only/read write”

i just tested it out on both picture albums i had and movie files that previously didnt work and sure enough they were set to “no access” for any users than my laptop. and now they all work.

this is great, the one an only issue i had with WD Live is now solved.

EDIT- just of note, if you make these changes while already connected to the network share, you will have to press the back button on the remote to go back to “network/youtube/media servers” then reconnect to your network share for the changes to show up on the player.


#2

?

where are you changing the properties?  on your PC or on the WDTV?

also, are you able to log into your YOUTUBE account?  i can’t even log in, when i log in, it says “No Content Available”  even though i have content on my YOUBTUBE ACCOUNT on my pc, saved videos, favorites, uploads.


#3

you have the change the properties of teh files themselves, nothing on the WD PLAYER

its really a bad job on WD’s part for not having the player regocnize the issue wasnt that the file wasnt a supported format, but that it simply wasnt accessable and having the message say that. thats why ive been thinking it was something to do with how the files were encoded.

as for youtube, ive never even tried.


#4

Well, actually what you say it’s true, if you have your permissions set incorrectly to not give you read access, then ofc the WDTV live is gonna complain that it can’t read the files, but this is not the only reason why it can give you that message.

It’s basically a generic way of saying that the device has tried to access that file and it hasn’t been able to, which could be due to a number of things: NTFS permissions on the files, permissions on the network share, firewall, network problems, unsupported codec and/or parameters in the file etc…

As for why the WDTV live doesn’t give you a more specific message I guess it’s because the PC only tells it that the access to that file was denied, so it can’t really throw a guess about what’s the problem.