I don't know what problem I'm having with my 1TB My Passport

I work on a Mac with 10.8 OSX and I’ve had my drive for several months now, but just within the past few days, I’ve ran into problems with it. It’s like it seems to be working fine, but then sometimes it stops working.

I run a “scratch file” for Photoshop on it, so Photoshop doesn’t hog my memory when I use the software. But all of a sudden, Photoshop refused to open up and gave me this error:

Screen Shot 2014-03-30 at 5.29.24 PM.png

I assumed there was something wrong with the scratch file on My Passport, so I took out all of the files I had on it and tried to reformat/erase the drive and reset the Photoshop scratch file on it.

But then it didn’t completely compress all of my data into ZIP folders like it should have, kept disconnecting by itself, and started scaring me half to death when I opened up the drive and it showed nothing but empty folders…As if I suddenly lost all of the data on it. Luckily, one of my important folders were correctly compressed and I don’t seem to have lost anything in it, but I lost most of my old work from another folder from the incorrect compression.

On top of that, I now have to force-eject My Passport every time I want to disconnect it, but it keeps telling me another program is using it (but won’t tell me what program) when there’s no other programs open or running on the Dock.

I tried to run the diagnosis tests through the Drive Utilities app and it says it passed it’s S.M.A.R.T test and the Quick Drive Test, but it failed the Complete Drive Test (but wouldn’t tell me why).

So it seems like there is something wrong with my drive, but I don’t know what it is or how to fix it. My Mac reads it fine and opens it fine, so I don’t think it’s a USB cord issue. I’ve already tried to reformat it and clean it out, but that doesn’t seem to work…


Unfortunately, if the disk failed a diagnostic test then it should be replaced under warranty for free. Please visit the following link for additional information:


I can try to return it to get it replaced, but I don’t know where it was bought. My parents ordered it for me and had it shipped to me, so I don’t know where they got it and I didn’t keep the box that it came in.

But for now, it seems to be okay. I don’t have to force-eject anymore and it’s not disconnecting itself anymore…I’ve installed TURBO drives on it and the firmware updater and so far, it’s worked fine again for the past 2 days. The only issues I have now is that it failed the Complete Drive Test and that Photoshop won’t detect it when I go to the Performance settings, but I did read up somewhere that said it wasn’t a good idea to put the scratch file on an external drive, but on a faster internal drive. So I’m not going to use it for Photoshop anymore…And I still don’t really trust My Passport, even though it seems to be fine now, so I’m going to try to test it out later by putting a few things on it that aren’t important and see if it works fine with them.